Message not fully read (response) for request AND incompatible wire format


I am trying ELasticsearch from code source (8.0.0) , and I am getting these warninigs:

java.lang.IllegalStateException: Message not fully read (response) for requestId [542], handler [org.elasticsearch.transport.TransportService$ContextRestoreResponseHandler/org.elasticsearch.transport.TransportService$ContextRestoreResponseHandler/org.elasticsearch.action.ActionListenerResponseHandler@718cf8e3/org.elasticsearch.action.ActionListener$DelegatingFailureActionListener/org.elasticsearch.action.ActionListener$MappedActionListener/org.elasticsearch.discovery.HandshakingTransportAddressConnector$1$1@3a6af532/org.elasticsearch.transport.TransportService$$Lambda$4906/0x00000008017f1340@6d125c93/org.elasticsearch.transport.TransportService$$Lambda$4907/0x00000008017f17e0@147ebe03], error [false]; resetting

[2021-03-04T11:20:17,119][WARN ][o.e.t.InboundHandler     ] [VSELK-DATA-02] Failed to deserialize response from [/]

Caused by: java.lang.IllegalArgumentException: remote node [{VSELK-MASTER-02}{0QUjVisNSyqFrgyxIn8L0A}{eDX4VaBZRpmMC3rbNDeV-Q}{}{}{m}{xpack.installed=true, transform.node=false}] is build [2dbd59bbe167b1942c9725693cc1e600856d3554] of version [8.0.0] but this node is build [52b7b7a2b10b4dd13910a2ba9737a9b223ece8d5] of version [8.0.0] which has an incompatible wire format

Could you tell me please why I am getting these warninig (Trying to make new cluster to keep updated of the new features ), So I am using the same configuration of my Prod cluster (Version 7.10.1)

OS: Debian 10
Java: java15

Thanks for your help.

As it says, these nodes are incompatible builds. You must use the same build for every node in the cluster.

1 Like

Thanks for your answer @DavidTurner ,

I did the same thing in all the nodes, The same java version and the same steps to build them !

GCC: 9.3.0
Java: 15
Libxml: 2-2.9.7
Boost: 1.71.0
binutils: 2.34
Patchel: 0.10

I did that in 5 nodes, and in all the nodes I am getting the same warnings

Sure, you might have used the same build tools, but you didn't use the same Elasticsearch version. One is this commit and the other is this different commit.

1 Like

so If I understand well, as I run git clone the first time to download Elasticsearch, If I run now git pull in all the nodes at the same time and then re-built them, this may solve the problem ?

IMO it'd be simplest to assemble Elasticsearch in one place then deploy that build everywhere. If you really want to built it multiple times then you should say exactly which commit you want, e.g. git fetch && git reset --hard 9fb707a08ab9c1f173188409503984256f4c82fc

1 Like

Thanks a lot for your answers :grin:,
I will try that and keep you updated

Thanks @DavidTurner ,

I tried your solution and worked perfectly for me ^ ^

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.