message: [WARN ][cluster.service ] [node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300]]


(HansPeterSloot) #1

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1] failed
to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException:
[node1][inet[/10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #2

Is/was there another elasticsearch node no the network? If you will only
have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot
hanspeter.sloot@gmail.comwrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1] failed
to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300
]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDwKkiCA%2BZ5uWv1Kk_BUXpHUVs3UUDr8WLc_perNN%3DGww%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(HansPeterSloot) #3

No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the
following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:

Is/was there another elasticsearch node no the network? If you will only
have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot <hanspet...@gmail.com<javascript:>

wrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f2a90e47-faeb-47a2-af46-7d9337be1bfb%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(HansPeterSloot) #4

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:

No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the
following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:

Is/was there another elasticsearch node no the network? If you will only
have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.comwrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #5

I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspeter.sloot@gmail.com) a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:
No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:
Is/was there another elasticsearch node no the network? If you will only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.com wrote:
Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52c282fa.542289ec.55aa%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(HansPeterSloot) #6

There is really no other elasticsearch node in the network. I am sure about
that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m
-Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch
-Des.default.path.data=/var/lib/elasticsearch
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1] failed
to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException:
[node1][inet[/10.10.10.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at
org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:

I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com<javascript:>)
a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:

No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the
following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:

Is/was there another elasticsearch node no the network? If you will only
have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.comwrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #7

Could you GIST (gist.github.com) the full log file please?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspeter.sloot@gmail.com) a écrit:

There is really no other elasticsearch node in the network. I am sure about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid -Des.path.home=/usr/share/elasticsearch -cp :/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/ -Des.default.path.home=/usr/share/elasticsearch -Des.default.path.logs=/var/log/elasticsearch -Des.default.path.data=/var/lib/elasticsearch -Des.default.path.work=/tmp/elasticsearch -Des.default.path.conf=/etc/elasticsearch org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]
at org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:
I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com) a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:
No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:
Is/was there another elasticsearch node no the network? If you will only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.com wrote:
Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52c29f41.32fff902.55aa%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(HansPeterSloot) #8

Never did that.

Is this what you need?

nl19856 https://gist.github.com/nl19856 / gist:8195274
https://gist.github.com/nl19856/8195274

Op dinsdag 31 december 2013 11:41:05 UTC+1 schreef David Pilato:

Could you GIST (gist.github.com) the full log file please?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspet...@gmail.com<javascript:>)
a écrit:

There is really no other elasticsearch node in the network. I am sure
about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m
-Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch
-Des.default.path.data=/var/lib/elasticsearch
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at
org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:

I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com) a
écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:

No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the
following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:

Is/was there another elasticsearch node no the network? If you will
only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.comwrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/85f4edd9-d377-49f8-bc42-362d3116f947%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #9

Sorry if I am unclear but I would like to see all the lines in your log file, from when you start the node to this issue.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 11:59:25, HansPeterSloot (hanspeter.sloot@gmail.com) a écrit:

Never did that.

Is this what you need?

nl19856 / gist:8195274

Op dinsdag 31 december 2013 11:41:05 UTC+1 schreef David Pilato:
Could you GIST (gist.github.com) the full log file please?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspet...@gmail.com) a écrit:

There is really no other elasticsearch node in the network. I am sure about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid -Des.path.home=/usr/share/elasticsearch -cp :/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/ -Des.default.path.home=/usr/share/elasticsearch -Des.default.path.logs=/var/log/elasticsearch -Des.default.path.data=/var/lib/elasticsearch -Des.default.path.work=/tmp/elasticsearch -Des.default.path.conf=/etc/elasticsearch org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]
at org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:
I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com) a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:
No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:
Is/was there another elasticsearch node no the network? If you will only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.com wrote:
Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/85f4edd9-d377-49f8-bc42-362d3116f947%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a43f.79a1deaa.55aa%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(HansPeterSloot) #10

Sorry for the confusion.
The file was so long I just thought that you only needed the error message.

Can you access this one?

nl19856 https://gist.github.com/nl19856 / gist:8195337
https://gist.github.com/nl19856/8195337

2013/12/31 David Pilato david@pilato.fr

Sorry if I am unclear but I would like to see all the lines in your log
file, from when you start the node to this issue.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 11:59:25, HansPeterSloot (hanspeter.sloot@gmail.com//hanspeter.sloot@gmail.com)
a écrit:

Never did that.

Is this what you need?

nl19856 https://gist.github.com/nl19856 / gist:8195274
https://gist.github.com/nl19856/8195274

Op dinsdag 31 december 2013 11:41:05 UTC+1 schreef David Pilato:

Could you GIST (gist.github.com) the full log file please?

 --

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspet...@gmail.com) a
écrit:

There is really no other elasticsearch node in the network. I am sure
about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m
-Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly
-XX:+HeapDumpOnOutOfMemoryError -Delasticsearch -Des.pidfile=/var/run/
elasticsearch/elasticsearch.pid -Des.path.home=/usr/share/elasticsearch
-cp :/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/
share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch
-Des.default.path.data=/var/lib/elasticsearch
-Des.default.path.work=/tmp/elasticsearch -Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/10.
10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]
at org.elasticsearch.transport.netty.NettyTransport.
connectToChannels(NettyTransport.java:693)
at org.elasticsearch.transport.netty.NettyTransport.
connectToNode(NettyTransport.java:622)
at org.elasticsearch.transport.netty.NettyTransport.
connectToNode(NettyTransport.java:590)
at org.elasticsearch.transport.TransportService.connectToNode(
TransportService.java:129)
at org.elasticsearch.cluster.service.InternalClusterService$
ReconnectToNodes.run(InternalClusterService.java:505)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /
10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(
SocketChannelImpl.java:592)
at org.elasticsearch.common.netty.channel.socket.nio.
NioClientBoss.connect(NioClientBoss.java:150)
at org.elasticsearch.common.netty.channel.socket.nio.
NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at org.elasticsearch.common.netty.channel.socket.nio.
NioClientBoss.process(NioClientBoss.java:79)
at org.elasticsearch.common.netty.channel.socket.nio.
AbstractNioSelector.run(AbstractNioSelector.java:318)
at org.elasticsearch.common.netty.channel.socket.nio.
NioClientBoss.run(NioClientBoss.java:42)
at org.elasticsearch.common.netty.util.
ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at org.elasticsearch.common.netty.util.internal.
DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:

I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

 --

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com)
a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:

No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the
following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:

Is/was there another elasticsearch node no the network? If you will
only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.comwrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%
40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/85f4edd9-d377-49f8-bc42-362d3116f947%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/aVeipLZ5s0c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a43f.79a1deaa.55aa%40MacBook-Air-de-David.local
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAM7K%2Bru2uXdsnB_atMpdHKwrM2u0ogsSqjBRk1e4zndJrKOaqg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #11

Thanks!

So you have your node running under IP: 10.192.21.69
It's trying to access another node at 10.10.10.1

So may be you modify elasticsearch.yml file or you have another node running with a different version on your network.

Could you run

curl http://10.10.10.1:9200/

?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 12:08:30, HansPeterSloot . (hanspeter.sloot@gmail.com) a écrit:

Sorry for the confusion.
The file was so long I just thought that you only needed the error message.

Can you access this one?

nl19856 / gist:8195337

2013/12/31 David Pilato david@pilato.fr
Sorry if I am unclear but I would like to see all the lines in your log file, from when you start the node to this issue.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 11:59:25, HansPeterSloot (hanspeter.sloot@gmail.com) a écrit:

Never did that.

Is this what you need?

nl19856 / gist:8195274

Op dinsdag 31 december 2013 11:41:05 UTC+1 schreef David Pilato:
Could you GIST (gist.github.com) the full log file please?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspet...@gmail.com) a écrit:

There is really no other elasticsearch node in the network. I am sure about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid -Des.path.home=/usr/share/elasticsearch -cp :/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/ -Des.default.path.home=/usr/share/elasticsearch -Des.default.path.logs=/var/log/elasticsearch -Des.default.path.data=/var/lib/elasticsearch -Des.default.path.work=/tmp/elasticsearch -Des.default.path.conf=/etc/elasticsearch org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]
at org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:
I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com) a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:
No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:
Is/was there another elasticsearch node no the network? If you will only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.com wrote:
Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/85f4edd9-d377-49f8-bc42-362d3116f947%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/aVeipLZ5s0c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a43f.79a1deaa.55aa%40MacBook-Air-de-David.local.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAM7K%2Bru2uXdsnB_atMpdHKwrM2u0ogsSqjBRk1e4zndJrKOaqg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a648.520eedd1.55aa%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #12

Sorry. Wrong answer.

It sounds like you have 2 network cards on your computer:

inet[/10.192.21.69:9200]}, publish_address {inet[/10.10.10.1:9200]}

You should set network.host

See: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.html#tcp-settings

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 12:11:07, David Pilato (david@pilato.fr) a écrit:

Thanks!

So you have your node running under IP: 10.192.21.69
It's trying to access another node at 10.10.10.1

So may be you modify elasticsearch.yml file or you have another node running with a different version on your network.

Could you run

curl http://10.10.10.1:9200/

?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 12:08:30, HansPeterSloot . (hanspeter.sloot@gmail.com) a écrit:

Sorry for the confusion.
The file was so long I just thought that you only needed the error message.

Can you access this one?

nl19856 / gist:8195337

2013/12/31 David Pilato david@pilato.fr
Sorry if I am unclear but I would like to see all the lines in your log file, from when you start the node to this issue.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 11:59:25, HansPeterSloot (hanspeter.sloot@gmail.com) a écrit:

Never did that.

Is this what you need?

nl19856 / gist:8195274

Op dinsdag 31 december 2013 11:41:05 UTC+1 schreef David Pilato:
Could you GIST (gist.github.com) the full log file please?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspet...@gmail.com) a écrit:

There is really no other elasticsearch node in the network. I am sure about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid -Des.path.home=/usr/share/elasticsearch -cp :/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/ -Des.default.path.home=/usr/share/elasticsearch -Des.default.path.logs=/var/log/elasticsearch -Des.default.path.data=/var/lib/elasticsearch -Des.default.path.work=/tmp/elasticsearch -Des.default.path.conf=/etc/elasticsearch org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]
at org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:
I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com) a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:
No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:
Is/was there another elasticsearch node no the network? If you will only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot hanspet...@gmail.com wrote:
Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ] [node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/85f4edd9-d377-49f8-bc42-362d3116f947%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/aVeipLZ5s0c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a43f.79a1deaa.55aa%40MacBook-Air-de-David.local.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAM7K%2Bru2uXdsnB_atMpdHKwrM2u0ogsSqjBRk1e4zndJrKOaqg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a6ab.649bb77c.55aa%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(HansPeterSloot) #13

Well the 10.10.10.1 is just another nic on the same node.

Op dinsdag 31 december 2013 12:11:04 UTC+1 schreef David Pilato:

Thanks!

So you have your node running under IP: 10.192.21.69
It's trying to access another node at 10.10.10.1

So may be you modify elasticsearch.yml file or you have another node
running with a different version on your network.

Could you run

curl http://10.10.10.1:9200/

?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 12:08:30, HansPeterSloot . (hanspet...@gmail.com<javascript:>)
a écrit:

Sorry for the confusion.
The file was so long I just thought that you only needed the error
message.

Can you access this one?

nl19856 https://gist.github.com/nl19856 / gist:8195337
https://gist.github.com/nl19856/8195337

2013/12/31 David Pilato <da...@pilato.fr <javascript:>>

Sorry if I am unclear but I would like to see all the lines in your log
file, from when you start the node to this issue.

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 11:59:25, HansPeterSloot (hanspet...@gmail.com<javascript:>)
a écrit:

Never did that.

Is this what you need?

nl19856 https://gist.github.com/nl19856 / gist:8195274
https://gist.github.com/nl19856/8195274

Op dinsdag 31 december 2013 11:41:05 UTC+1 schreef David Pilato:

Could you GIST (gist.github.com) the full log file please?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspet...@gmail.com)
a écrit:

There is really no other elasticsearch node in the network. I am sure
about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m
-Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch
-Des.default.path.data=/var/lib/elasticsearch
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at
org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /
10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:

I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com)
a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:

No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the
following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:

Is/was there another elasticsearch node no the network? If you will
only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot <hanspet...@gmail.com

wrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ]
[node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/85f4edd9-d377-49f8-bc42-362d3116f947%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/aVeipLZ5s0c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a43f.79a1deaa.55aa%40MacBook-Air-de-David.local.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAM7K%2Bru2uXdsnB_atMpdHKwrM2u0ogsSqjBRk1e4zndJrKOaqg%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/230194d9-ec9c-49a4-a47a-f024d8a187cb%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(HansPeterSloot) #14

Yes that worked.
Thanks a lot.

Op dinsdag 31 december 2013 12:12:43 UTC+1 schreef David Pilato:

Sorry. Wrong answer.

It sounds like you have 2 network cards on your computer:

inet[/10.192.21.69:9200]}, publish_address {inet[/10.10.10.1:9200]}

You should set network.host

See:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-network.html#tcp-settings

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 12:11:07, David Pilato (da...@pilato.fr<javascript:>)
a écrit:

Thanks!

So you have your node running under IP: 10.192.21.69
It's trying to access another node at 10.10.10.1

So may be you modify elasticsearch.yml file or you have another node
running with a different version on your network.

Could you run

curl http://10.10.10.1:9200/

?

  -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 12:08:30, HansPeterSloot . (hanspet...@gmail.com<javascript:>)
a écrit:

Sorry for the confusion.
The file was so long I just thought that you only needed the error
message.

Can you access this one?

nl19856 https://gist.github.com/nl19856 / gist:8195337
https://gist.github.com/nl19856/8195337

2013/12/31 David Pilato <da...@pilato.fr <javascript:>>

Sorry if I am unclear but I would like to see all the lines in your log
file, from when you start the node to this issue.

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 11:59:25, HansPeterSloot (hanspet...@gmail.com<javascript:>)
a écrit:

Never did that.

Is this what you need?

nl19856 https://gist.github.com/nl19856 / gist:8195274
https://gist.github.com/nl19856/8195274

Op dinsdag 31 december 2013 11:41:05 UTC+1 schreef David Pilato:

Could you GIST (gist.github.com) the full log file please?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 10:41:32, HansPeterSloot (hanspet...@gmail.com)
a écrit:

There is really no other elasticsearch node in the network. I am sure
about that.

There is also only one daemon running:
ps -ef|grep elast
101 1769 1 1 08:27 ? 00:02:14 /usr/bin/java -Xms256m
-Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.pidfile=/var/run/elasticsearch/elasticsearch.pid
-Des.path.home=/usr/share/elasticsearch -cp
:/usr/share/elasticsearch/lib/elasticsearch-0.90.7.jar:/usr/share/elasticsearch/lib/:/usr/share/elasticsearch/lib/sigar/
-Des.default.path.home=/usr/share/elasticsearch
-Des.default.path.logs=/var/log/elasticsearch
-Des.default.path.data=/var/lib/elasticsearch
-Des.default.path.work=/tmp/elasticsearch
-Des.default.path.conf=/etc/elasticsearch
org.elasticsearch.bootstrap.ElasticSearch
root 2271 2246 0 10:23 pts/21 00:00:00 grep elast

The full entry is:
[2013-12-31 10:24:13,554][WARN ][cluster.service ] [node1]
failed to reconnect to node [node1][KhPM-quUTlmGAjpZoQjH5Q][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:693)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:622)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:590)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:129)
at
org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:505)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)
Caused by: java.net.ConnectException: Connection refused: /
10.10.10.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
... 3 more

The machine has 2 nics.
One ip address is 10.10.10.1.

Regards HansP

Op dinsdag 31 december 2013 09:40:26 UTC+1 schreef David Pilato:

I agree with Ivan. You should have another running.
Is 10.10.10.1 your IP address?

Could you gist your full log?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 31 décembre 2013 at 09:38:26, HansPeterSloot (hanspet...@gmail.com)
a écrit:

It seems that it is not enough.
The message keeps appearing.

Op dinsdag 31 december 2013 08:43:08 UTC+1 schreef HansPeterSloot:

No there is only 1 node.
Is is sufficient to remove the # in the elasticsearch.yml before the
following entry:
discovery.zen.ping.multicast.enabled: false

Regards HansP

Op maandag 30 december 2013 20:25:25 UTC+1 schreef Ivan Brusic:

Is/was there another elasticsearch node no the network? If you will
only have 1 node, you can disable mutlicast discovery.

--
Ivan

On Mon, Dec 30, 2013 at 3:33 AM, HansPeterSloot <hanspet...@gmail.com

wrote:

Hi,

I have a 1 node elasticsearch cluster which seems to run fine.
But I see the following messages in the logfile:
[2013-12-30 12:17:35,905][WARN ][cluster.service ]
[node1] failed to reconnect to node [node1][I4Wltlc9RSm0jJhumBRtpQ][inet[/
10.10.10.1:9300]]
org.elasticsearch.transport.ConnectTransportException: [node1][inet[/
10.10.10.1:9300]] connect_timeout[30s]

What can I do to get rid of it?

Regards HansP

You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3f9fe20f-6fed-475d-88f3-7441d01ff816%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f7fa1c06-c099-4c38-83b0-2a5aba30b371%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/119be7db-2c10-427c-9c5a-c747f928bd0a%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/85f4edd9-d377-49f8-bc42-362d3116f947%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/aVeipLZ5s0c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.52c2a43f.79a1deaa.55aa%40MacBook-Air-de-David.local.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAM7K%2Bru2uXdsnB_atMpdHKwrM2u0ogsSqjBRk1e4zndJrKOaqg%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0e25294a-b938-45ef-9ad5-e49ef9fd7516%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #15