Metricbeat 5.1.2 does not start automatically


#1

Hi, Elastic team

I have Metricbeat 5.1.2 installed on Client machine (Windows 7 32-bit). It does not start automatically (other Beats - Filebeat, Winlogbeat, Packetbeat, and Heartbeat - started automatically without problem).

How to make it started automatically?

Thanks,
Dmitry


(Andrew Kroh) #2

Could you try a newer version? We fixed something in ~5.2 to slowed the startup and it timed out.


#3

I’ll install it on my machine but here is a question: is it compatible with Logstash 5.12/Elasticsearch 5.1.2 installed on Server machine?

Thanks,
Dmitry


(Andrew Kroh) #4

Yeah, those versions should work fine.


#5

Hi, Andrew

I have Beats installed on my machine

Beat name

Version

Automatically start

Notes

Filebeat

5.1.2

Yes

Packetbeat

5.1.2

Yes

Heartbeat

5.1.2

Yes

Winlogbeat

5.1.2

No

When started manually shows Error 1053

Metricbeat

5.2.2

No

When started manually shows Error 1053

[/uploads/default/original/3X/4/7/47052db2283829afa54de4dad78f433303f1f847.jpg]

Attached you’ll find all 5 .yml files.

Please help with that problem.

Thanks,
Dmitry


(Andrew Kroh) #6

So both Winlogbeat and Metricbeat failed at startup?

Sounds like the same issue as Metricbeat Windows fails to start on reboot - timeout

A workaround until we know what the cause, is to modify the service to use "Automatic Delayed Start". That's according to a report in the thread linked above.


#7

Workaround did not help – I changed service to “Automatic (Delayed Start)” and did restart.

[/uploads/default/original/3X/8/4/84137804dc4cfa30a6a4a6ed1204381f1ead5959.jpg]

Thanks,
Dmitry


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.