Metricbeats does not start Win2012 R1 x64


#1

Hi,

I installed metricbeats 5.1.2 on Win2012 R1 x64. On DEV and QA stage everything is fine. Using same OS, same configuration, etc.

Copied the the files from there to prod, but on prod I have a strange behavior:
The service cannot be started because it took too long.

Tried to debug. Ran metricbeat --help from cmd. I get no error message and no output on cmd.

I also retransfered the files from qa again in case the binaries have been corrupted. But still the same issue.

What could be the problem?
Are there any dependencies which are needed? So if I could doublecheck if they are really the same on prod / qa.

Thanks, Andreas


#2

dont' know if it helps to determine the error.
Currently there is also topbeat 1.2.3 running on this server. But currently we have the issue, that topbeat can be started, but it is gathering no events. But topbeat --help is working.

Problem stays when using metricbeat 5.2.1. Tried 32 and 64 bit version. No difference.


(ruflin) #3

Can you run metricbeat with -e -d "*" and post the output here?


#4

unfortunately nothing. no output, seems to hang :frowning:


(ruflin) #5

What is the command you use to start metricbeat (including full path) and how did install metricbeat?


(system) #6

This topic was automatically closed after 21 days. New replies are no longer allowed.