Metricbeat 6.0.0 Problem getting metrics from windows and linux Hosts


I'm testing Metricbeat 6.0.0 and i have some problem to get metrics in kibana from linux and windows hosts
1- I load the sample dashboard from the Windows Host
2- I start metricbeat from the same windows host (i've tried directly to elasticsearch or through logstash but the problem persist)
3- I stop metricbeat from the same windows host (When i check in command line an index metricbeat-6.0.0-date is created in Elasticsearch)
4- I start metricbeat from the linux hosts (When i check the same index metricbeat-6.0.0-date get new documents so i'm sure the linux metrics are in the index !)
5- In kibana importing the sample dashboard automaticaly created the metricbeat-* index pattern
6-In kibana in discover and visualization/dashbords, I only see windows host metric. When i search for the deb* there is no result ( When I've tried with logstash in debug mode i saw the metrics with "beat" => { "name" => "debian8" ).

I've tried the same process without importing the default dashboard or by deleting and re-creating the metricbeat-* index pattern. I've also tried to store metrics from linux in index metricbeat-linux-date and metrcis from windows in metricbeat-windows-date but none of it solve my problem. I've searched a solution but i'm stuck.

Is there a way to merge metric from linux and windows host or is it impossible ?

Sorry for my bad english.
thank you for your help.

The problem solved itself after 1hour... realy strange, it seems there's a delay before Kibana show up Linux metrics

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.