Metricbeat and MySQL doesnt show results


(Fernando Ramirez) #1

Hi

I run ELK in serverA.

Kibana 5.6
Elasticsearch 5.6
Logstash 5.6

And, in a second serverB I have installed metricbeat 5.6 version to monitoring the MySQL database.

metricbeat 5.6
mysql 5,7

The configuration file is:

#==========================  Modules configuration ============================
metricbeat.modules:

#-------------------------------- MySQL Module -------------------------------
- module: mysql
  metricsets: ["status"]
  enabled: true
  period: 5s

  # Host DSN should be defined as "user:pass@tcp(127.0.0.1:3306)/"
  # The username and password can either be set in the DSN or using the username
  # and password config options. Those specified in the DSN take precedence.
  # hosts: ["tcp(127.0.0.1:3306)/"]
  hosts: ["user:pass@tcp(127.0.0.1:3306)/"]

I replace the user and pass for a user valid.

I use logstash to send the data to Kibana in serverA

#----------------------------- Logstash output --------------------------------
output.logstash:
  # The Logstash hosts
  hosts: ["202.222.22.22:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

I assign the level of log in: debug

And the logs show me:

2018-05-15T18:17:10-05:00 DBG  Publish: {
  "@timestamp": "2018-05-15T23:17:10.759Z",
  "beat": {
    "hostname": "ip-172-XX-XX-XX.ec2.internal",
    "name": "ip-172-XX-XX-XX.ec2.internal",
    "version": "5.6.9"
  },
  "error": "this authentication plugin is not supported",
  "metricset": {
    "host": "127.0.0.1:3306",
    "module": "mysql",
    "name": "status",
    "rtt": 447
  },
  "mysql": {
    "status": {}
  },
  "type": "metricsets"
}

And the Kibana doens't show me any results of Metricbeat MySQL module.

  • I missing a parameters in process of configuration ?

Please your help to resolve this issue.

Thanks in advance for your help.


(Pier-Hugues Pellerin) #2

Did you try with a newer version of metricbeat 6.2.4 if the problem is solved?


(Fernando Ramirez) #3

Thanks a lot this respond resolve my issue


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.