Metricbeat/K8s: "error getting group status: open /proc/<PID>/cgroup"

Running Metricbeat on AKS v1.16.3, seeing the following error in logs:

instance/metrics.go:285 error getting group status: open /proc/<PID>/cgroup: no such file or directory"

I'm new to beats and, after several hours of searching (and fiddling with system module's "process.cgroups.enabled"), i'm getting nowhere. Any suggestions or pointers to resources would be very much appreciated.

6 Likes

hello @jwhitehead I was wondering whether you have any updates as I am encountring the same error.
Thanks

Seeing the same issue as well on AKS 1.19.3

I'm seeing the same thing on AKS v1.18 and Metricbeat 7.10.0. It seems like Metricbeat isn't respecting the system.hostfs flag because I can see the directory it's looking for at /hostfs/proc/<PID>/cgroup, but it's looking in /proc/<PID>/cgroup.

Hi! I have the same thing, has anyone found a solution to the problem?

Same issue, solution ?

Got the same error. Just posting to prevent this topic from stalling

This error is not related to Metricbeat's system module, but to a new feature in Beats internal monitoring.

The system module is still understanding the -system.hostfs flag and reporting metrics correctly. The only effect of this error is that the internal monitoring metrics from Metricbeat are lacking the new cgroups data.

See this issue for more information: https://github.com/elastic/beats/issues/23267

@adrisr
I have the same error like the others , how can i disable this metric until the bug is fixed ?

Metrics reporting can be disabled by adding the following to your Beat configuration:

monitoring.enabled: false

This will, of course, disable all internal monitoring.

Any updates on if this issue is resolved?