Metricbeat module with Kubernetes cluster v1.19.2

hi all,
do you have any news about the compatibility between Metricbeat and Kubernetes version 1.19.x?
I saw that starting from K8s 1.19, the components controller-manager and scheduler have been deprecated.

I mean, can I still use it without any problem? currently I would like to avoid to install Metricbeat with this doubt since I have only one K8s cluster.