Metricbeat return all filesystems

For some reason, metricbeat 7.1 refuses to send all devices to elasticsearch 7.1. I have disabled the filtering, below is my /elasticsearch/modules.d/system.yml file:
# Module: system
# Docs:

- module: system
  period: 10s
    - cpu
    - load
    - memory
    - network
    - process
    - process_summary
    - socket_summary
    #- core
    #- diskio
    #- socket
    by_cpu: 5      # include top 5 processes by CPU
    by_memory: 5   # include top 5 processes by memory

- module: system
  period: 1m
    - filesystem
    - fsstat
  filesystem.ignore_types: [none]

- module: system
  period: 15m
    - uptime

I want to be able to display all drives, rather than just the first one. Even when I disable the filters, I only get the first one, and I want to be able to see all of the df -h table from kibana.

Filesystem      Size  Used Avail Use% Mounted on
/dev/sda2       385G   16G  350G   5% /
tmpfs            63G   72K   63G   1% /dev/shm
/dev/sda1       477M  146M  306M  33% /boot
/dev/sda6       3.2T  165G  2.9T   6% /data
/dev/sdb1       1.1T  844G  272G  76% /data2
/dev/sda5       481G  222G  235G  49% /home
/dev/sda3        24G   15G  8.7G  62% /var

Facing same thing with 6.6.0 - cannot fetch other volumes metrics. Only DiskIO is working with other volumes(/dev/vdb in my case) but not fsstat/filesystem metrics.
Also tried next approach fsstat.include_devices: ["vda", "vdb"] - it didnt worked seems.

I assume you've solved your issue. Can you add your solutions, since others might run into the same problem and could learn from it :)?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.