Metricbeat Setup not work

Hello guys,
I need help to fix this:

mservice@sentinel:~$ sudo metricbeat setup
Exiting: Couldn't connect to any of the configured Elasticsearch hosts. Errors: [Error connection to Elasticsearch http://localhost:5044: Get http://localhost:5044: dial tcp [::1]:5044: getsockopt: connection refused]

I think that is the firewall blocking, I'm using Ubuntu Server 18.04 and install ELK via repositories.if it is the firewall, how can I open the ports?

It looks like you have configured it to connect to Elasticsearch on port 5044, but 5044 is normally the Logstash port. Normally Elasticsearch listens on 9200 (http) or 9243 (https).

Or if you intended to send the data to Logstash then double check your configuration to ensure that you have fully removed output.elasticsearch and any related config that's under it.


@andrewkroh thank you by report I reviewed my metricbeatfile.yml and was set output in both elastic and logstash...

So I try running and:

mservice@sentinel:~$ sudo metricbeat setup
Loaded index template
Loading dashboards (Kibana must be running and reachable)
Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: Error creating Kibana client: can not convert 'object' into 'string' accessing '' (source:'/etc/metricbeat/metricbeat.yml')

That would mean you have an invalid value for in your configuration file. It needs to be a string.

See for examples and docs.

1 Like

@andrewkroh thank by feedback, but I already had configured...I change to IP following the tutorial, and the error persists...

Currently my firewall it's disable:

mservice@sentinel:~$ sudo ufw status
Status: inactive

mservice@sentinel:~$ sudo netstat -plnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0*               LISTEN      6189/node
tcp        0      0    *               LISTEN      6260/nginx: master
tcp        0      0 *               LISTEN      536/systemd-resolve
tcp        0      0    *               LISTEN      798/sshd
tcp6       0      0     :::*                    LISTEN      6113/java
tcp6       0      0     :::*                    LISTEN      6113/java
tcp6       0      0 :::22                   :::*                    LISTEN      798/sshd

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.