Metricbeat socket stats - metricbeat

hi - trying to enable metricbeat socket stats on linux server (VM). Tried following the documentation steps, but still don't see the socket stats sent to elastic. We are running metricbeat as root and so permissions is not an issue. Please let me know what else might be missing...

Elastic - v7.13 Beats - v7.11
RHEL - 7.9

Here is the metricbeat yml

metricbeat.config.modules:
  path.config: /path/metricbeat/current_metricbeat

metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: true
  reload.period: 10s

metricbeat.modules:
- module: system
  metricsets: [cpu]
  cpu.metrics: [percentages,normalized_percentages]

- module: system
  metricsets: [process]
  processes: ['.*']
  process.cgroups.enabled: false
  process.cmdline.cache.enabled: true
  process.include_top_n:
    by_cpu: 20      # include top 20  processes by CPU
    by_memory: 20   # include top 20  processes by memory

- module: system
  period: 10m
  metricsets:
    - filesystem
    - fsstat
  filesystem.ignore_types: [nfs, smbfs, autofs, rpc_pipefs, rootfs]
  processors:
  - drop_event.when.regexp:
      system.filesystem.mount_point: '^/(dev|run|sys|fs|host|lib|tmpfs|boot|proc)($|/)'

- module: system
  period: 10s
  metricsets:
    - load
    - memory
    - network
    - process_summary
    - diskio

- module: system
  period: 15m
  metricsets:
    - uptime

- module: system
  metricsets: [core]
  core.metrics: [percentages]

- module: system
  metricsets: [socket] 
  period: 1s

setup.template.enabled: false

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression

output.elasticsearch:
  index: "metrics_index-%{[agent.version]}-%{+yyyy.MM.dd}"
  hosts: ["http://oo-elastic08.dm.com:port", "http://oo-elastic09.dm.com:port", "http://oo-elastic10.dm.com:port"]
  username: mid
  password: pwd
setup.template.name: "metrics_index"
setup.template.pattern: "metrics_index-*"
setup.template.overwrite: false