MetricBeats || Apache ActiveMq|| Origin null is not allowed

Hi Team,
Trying to setup metricbeat for ActiveMq, whole installation and configuration process went smooth, but couldn't see any data on Kibana.
On further diagnosis, found below information in /var/log/messages.

metricbeat: 2020-05-12T15:19:32.478+0530#011INFO#011module/wrapper.go:252#011Error fetching data for metricset activemq.broker: failed to unmarshal jolokia JSON response '{"error_type":"java.lang.Exception","error":"java.lang.Exception : Origin null is not allowed to call this agent","status":403}': json: cannot unmarshal object into Go value of type []jmx.Entry 

ActiveMq Version: 5.15.12 [ Default configuration ]
Elastic Version: 7.6

Hey @faiz0210, welcome to discuss :slight_smile:

ActiveMQ module requires the Jolokia agent installed in your ActiveMQ broker, is it installed in your case? You may also need to configure an username and password if the endpoint requires authentication.

Hi Jaime,

Thank you for the reply.
I can see that jolokia-core-1.6.2.jar is already integrated inside the ActiveMQ and it's listening on port 8161.

Although, when I run curl manually on the port, it gave me the same error "Origin null is not allowed to call this agent", but if I pass a header in curl request as "Origin:localhost", it is providing a lot of information in json.

So, I tried passing the same header in activemq.yml, the error disappeared and I can see data in metricbeat index, though default dashboard is still not showing any data.
Hopefully I should be able to resolve that as well.

There are dashboard for activemq brokers, topics and queues, none of them show any data?

Do you see any error in kibana when opening these dashboards?

Could you share some of the events that are being collected?

Apologies for not updating. I was able to fix the Kibana dashboard issue as well.

The dashboard json file has index defined in the "default_index_pattern" instead of "index_pattern".

Once I changed my metricbeat index to default index, it started working.

Although, I am curious why index is defined in "default_index_pattern" instead of "index_pattern".