Metrics: There is no data to display (error while fetching resource)


I have som troubles with metricbeat and Metrics App in Kibana. I am using metricbeat 7.10 and Kibana 7.10 on a Windows Server 2019.

Every now and then I get an error message when I open Metrics App in Kibana: Error while fetching resource (Internal server error 500). I couldn't find any log messages that could help me.

I have tried loading the metricbeat template as suggested here (Kibana Metrics – 500 Internal Server Error - #2 by ntk).

I have a metricbeat template, so I loaded the template like

 PUT _template/metricbeat_template 
 template from PS > .\metricbeat.exe export template --es.version 7.10.0 | Out-File -Encoding UTF8 metricbeat.template.json)


 PUT metricbeat-000001
         "aliases" : {
             "metricbeat": {  
                 "is_write_index": true

but I still get this error.

Metricbeat is running as a service, and ships the data to logstash, which does the following:

filter {
  mutate {
    add_field => { "type" => "%{[@metadata][beat]}" }
output {
  elasticsearch {
    hosts => ["https://xxx:9200"]
    index => "%{[type]}"
	cacert => "certificate"
	user => user
	password => password

The metricbeat log says:

2021-02-24T15:15:15.937+0100	INFO	[index-management]	idxmgmt/std.go:407	Set to '{metricbeat-7.10.0 {now/d}-000001}' as ILM is enabled.
2021-02-24T15:15:15.937+0100	INFO	[index-management]	idxmgmt/std.go:412	Set setup.template.pattern to 'metricbeat-7.10.0-*' as ILM is enabled.
2021-02-24T15:15:15.937+0100	INFO	[index-management]	idxmgmt/std.go:446	Set settings.index.lifecycle.rollover_alias in template to {metricbeat-7.10.0 {now/d}-000001} as ILM is enabled.
2021-02-24T15:15:15.938+0100	INFO	[index-management]	idxmgmt/std.go:450	Set in template to {metricbeat {"policy":{"phases":{"hot":{"actions":{"rollover":{"max_age":"30d","max_size":"50gb"}}}}}}} as ILM is enabled.
2021-02-24T15:15:15.938+0100	INFO	template/load.go:183	Existing template will be overwritten, as overwrite is enabled.
2021-02-24T15:15:17.185+0100	INFO	[index-management]	idxmgmt/std.go:298	Loaded index template.

I can see metricbeat-00001 (since I defined it). The Kibana Index is metricbeat*.

Is it allowed to define a template, or is this a problem. As I said before, I have this problem every now and then. As we are still in development I do not have a look at it every day. So I have the suspicion that this happens after a rollover. And now the fix as described above does not work any more.
Any suggestion on what to do, to fix this problem?

Thanks in advance :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.