Missing Documents


(Luan Garrido) #1

Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post, and I
did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20
documents.
After some searchs in theese, it become only 13 documents.... I really dont
know why.
Can someone help me? I just dont know what to do.

Thanks =D

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(vineeth mohan-2) #2

Hello Luan ,

This is not possible.
Either you have deleted some documents.
Or there was another machine in the cluster to which the index shared the
documents.
And when the other machine went down , you lose data with it.

Hence I would recommend to add a unique name here - cluster.name ( This is
a config variable in config/elasticsearch.yml file)
If the problem persist , please paste the entire set of steps you followed.

Thanks
Vineeth

On Thu, Sep 4, 2014 at 3:27 AM, Luan Garrido lbgarrido89@gmail.com wrote:

Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post, and
I did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20
documents.
After some searchs in theese, it become only 13 documents.... I really
dont know why.
Can someone help me? I just dont know what to do.

Thanks =D

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGdPd5m-g7vzzqgn%2BKT7cai-L_E%3D6eisdbyPTbo8Zc5skc93WQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Luan Garrido) #3

Hi, Im waiting until it happens again, because it is not every time.
I have just one pc on my cluster =D.

Can you answer others questions until this?
1- Im using JAVA API, and Im deleting index using
"client().admin().indices().delete(new
DeleteIndexRequest("_all")).actionGet();". This is really removing all
indexes, but, when I restart ES theese index come back. I also tried to
remove manually it from the directories, and nothing happened.

Last question, I promisse =D
2- Im using a brazilian analyzer to index my documents, something like this:

"local5" : {
"settings" : {
"index" : {
"uuid" : "1qCOtEZQQ4Cd6lbu-0GB5A",
"analysis" : {
"analyzer" : {
"brazilian" : {
"filter" : [ "lowercase", "brazilian_stop", "brazilian_stemmer" ],
"tokenizer" : "standard"
}
},
"filter" : {
"brazilian_stop" : {
"type" : "stop",
"stopwords" : "brazilian"
},
"brazilian_stemmer" : {
"type" : "stemmer",
"language" : "brazilian"
}
}
},
"number_of_replicas" : "1",
"number_of_shards" : "5",
"version" : {
"created" : "1030299"
}
}
}
}

And Im tring to recovever theese documents using
client.prepareSearch("local5").setType("_all").setQuery(QueryBuilders.queryString(KEY+":"+VALUE)).

Im not able to identify words like "melhorias"(plural) using
"melhoria"(singular).

Can yo help me? I really appretiace. I didnt sleep until now hahahahaha


Luan Barbosa Garrido

CAPGov - Centro de Apoio a Políticas de Governo
PESC / COPPE / UFRJ

Bacharel em Ciência da Computação - DCC / IM / UFRJ
Mestrando em Banco de Dados - PESC / COPPE / UFRJ

2014-09-03 21:58 GMT-03:00 vineeth mohan vm.vineethmohan@gmail.com:

Hello Luan ,

This is not possible.
Either you have deleted some documents.
Or there was another machine in the cluster to which the index shared the
documents.
And when the other machine went down , you lose data with it.

Hence I would recommend to add a unique name here - cluster.name ( This
is a config variable in config/elasticsearch.yml file)
If the problem persist , please paste the entire set of steps you
followed.

Thanks
Vineeth

On Thu, Sep 4, 2014 at 3:27 AM, Luan Garrido lbgarrido89@gmail.com
wrote:

Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post, and
I did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20
documents.
After some searchs in theese, it become only 13 documents.... I really
dont know why.
Can someone help me? I just dont know what to do.

Thanks =D

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/QhpNIabG2es/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGdPd5m-g7vzzqgn%2BKT7cai-L_E%3D6eisdbyPTbo8Zc5skc93WQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAGdPd5m-g7vzzqgn%2BKT7cai-L_E%3D6eisdbyPTbo8Zc5skc93WQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALESzpRoFf65qM_p3%3DbAo0nHXfhiY5KAS1hiHZwf7%3DbbzKn%2B3w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Luan Garrido) #4

Hi, Im waiting until it happens again, because it is not every time.
I have just one pc on my cluster =D.

Can you answer others questions until this?
1- Im using JAVA API, and Im deleting index using
"client().admin().indices().delete(new
DeleteIndexRequest("_all")).actionGet();". This is really removing all
indexes, but, when I restart ES theese index come back. I also tried to
remove manually it from the directories, and nothing happened.

Last question, I promisse =D
2- Im using a brazilian analyzer to index my documents, something like this:

"local5" : {
"settings" : {
"index" : {
"uuid" : "1qCOtEZQQ4Cd6lbu-0GB5A",
"analysis" : {
"analyzer" : {
"brazilian" : {
"filter" : [ "lowercase", "brazilian_stop", "brazilian_stemmer" ],
"tokenizer" : "standard"
}
},
"filter" : {
"brazilian_stop" : {
"type" : "stop",
"stopwords" : "brazilian"
},
"brazilian_stemmer" : {
"type" : "stemmer",
"language" : "brazilian"
}
}
},
"number_of_replicas" : "1",
"number_of_shards" : "5",
"version" : {
"created" : "1030299"
}
}
}
}

And Im tring to recovever theese documents using client.prepareSearch("local5").setType("_all").setQuery(QueryBuilders.queryString(KEY+":"+VALUE)).

Im not able to identify words like "melhorias"(plural) using "melhoria"(singular).

Can yo help me? I really appretiace. I didnt sleep until now hahahahaha

Em quarta-feira, 3 de setembro de 2014 21h58min34s UTC-3, vineeth mohan
escreveu:

Hello Luan ,

This is not possible.
Either you have deleted some documents.
Or there was another machine in the cluster to which the index shared the
documents.
And when the other machine went down , you lose data with it.

Hence I would recommend to add a unique name here - cluster.name ( This
is a config variable in config/elasticsearch.yml file)
If the problem persist , please paste the entire set of steps you
followed.

Thanks
Vineeth

On Thu, Sep 4, 2014 at 3:27 AM, Luan Garrido <lbgar...@gmail.com
<javascript:>> wrote:

Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post, and
I did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20
documents.
After some searchs in theese, it become only 13 documents.... I really
dont know why.
Can someone help me? I just dont know what to do.

Thanks =D

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2610a7ad-3605-4695-a9a2-3213152b9db2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(vineeth mohan-2) #5
  1. How did you come to the conclusion that every index was deleted ? If
    you are using head or some othedr UI , please paste the screenshot.
  2. Which folder are you deleting to remove the data ?
  3. Please check if multiple instances of Elasticsearch is running on
    your machine

Thanks
Vineeth

On Thu, Sep 4, 2014 at 4:12 PM, Luan Garrido lbgarrido89@gmail.com wrote:

Hi, Im waiting until it happens again, because it is not every time.
I have just one pc on my cluster =D.

Can you answer others questions until this?
1- Im using JAVA API, and Im deleting index using
"client().admin().indices().delete(new DeleteIndexRequest("_all")).actionGet();".
This is really removing all indexes, but, when I restart ES theese index
come back. I also tried to remove manually it from the directories, and
nothing happened.

Last question, I promisse =D
2- Im using a brazilian analyzer to index my documents, something like
this:

"local5" : {
"settings" : {
"index" : {
"uuid" : "1qCOtEZQQ4Cd6lbu-0GB5A",
"analysis" : {
"analyzer" : {
"brazilian" : {
"filter" : [ "lowercase", "brazilian_stop", "brazilian_stemmer" ],
"tokenizer" : "standard"
}
},
"filter" : {
"brazilian_stop" : {
"type" : "stop",
"stopwords" : "brazilian"
},
"brazilian_stemmer" : {
"type" : "stemmer",
"language" : "brazilian"
}
}
},
"number_of_replicas" : "1",
"number_of_shards" : "5",
"version" : {
"created" : "1030299"
}
}
}
}

And Im tring to recovever theese documents using client.prepareSearch("local5").setType("_all").setQuery(QueryBuilders.queryString(KEY+":"+VALUE)).

Im not able to identify words like "melhorias"(plural) using "melhoria"(singular).

Can yo help me? I really appretiace. I didnt sleep until now hahahahaha

Em quarta-feira, 3 de setembro de 2014 21h58min34s UTC-3, vineeth mohan
escreveu:

Hello Luan ,

This is not possible.
Either you have deleted some documents.
Or there was another machine in the cluster to which the index shared the
documents.
And when the other machine went down , you lose data with it.

Hence I would recommend to add a unique name here - cluster.name ( This
is a config variable in config/elasticsearch.yml file)
If the problem persist , please paste the entire set of steps you
followed.

Thanks
Vineeth

On Thu, Sep 4, 2014 at 3:27 AM, Luan Garrido lbgar...@gmail.com wrote:

Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post,
and I did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20
documents.
After some searchs in theese, it become only 13 documents.... I really
dont know why.
Can someone help me? I just dont know what to do.

Thanks =D

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2610a7ad-3605-4695-a9a2-3213152b9db2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2610a7ad-3605-4695-a9a2-3213152b9db2%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGdPd5nMe%2BAe1zT4SPDkuY8PtJVX_KVMCQaqUriD_JEGFhpGtg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Luan Garrido) #6

Hi Vineeth,
I made it. I manually deleted the folders in $ES$/data/elasticsearch, but
it have being created every time.
I took a look, We need to delete it from project workspace and from jboss
data.
Remove theese 3 directory and everything will work =D
Thank you

Em quinta-feira, 4 de setembro de 2014 10h15min40s UTC-3, vineeth mohan
escreveu:

  1. How did you come to the conclusion that every index was deleted ?
    If you are using head or some othedr UI , please paste the screenshot.
  2. Which folder are you deleting to remove the data ?
  3. Please check if multiple instances of Elasticsearch is running on
    your machine

Thanks
Vineeth

On Thu, Sep 4, 2014 at 4:12 PM, Luan Garrido <lbgar...@gmail.com
<javascript:>> wrote:

Hi, Im waiting until it happens again, because it is not every time.
I have just one pc on my cluster =D.

Can you answer others questions until this?
1- Im using JAVA API, and Im deleting index using
"client().admin().indices().delete(new DeleteIndexRequest("_all")).actionGet();".
This is really removing all indexes, but, when I restart ES theese index
come back. I also tried to remove manually it from the directories, and
nothing happened.

Last question, I promisse =D
2- Im using a brazilian analyzer to index my documents, something like
this:

"local5" : {
"settings" : {
"index" : {
"uuid" : "1qCOtEZQQ4Cd6lbu-0GB5A",
"analysis" : {
"analyzer" : {
"brazilian" : {
"filter" : [ "lowercase", "brazilian_stop", "brazilian_stemmer" ],
"tokenizer" : "standard"
}
},
"filter" : {
"brazilian_stop" : {
"type" : "stop",
"stopwords" : "brazilian"
},
"brazilian_stemmer" : {
"type" : "stemmer",
"language" : "brazilian"
}
}
},
"number_of_replicas" : "1",
"number_of_shards" : "5",
"version" : {
"created" : "1030299"
}
}
}
}

And Im tring to recovever theese documents using client.prepareSearch("local5").setType("_all").setQuery(QueryBuilders.queryString(KEY+":"+VALUE)).

Im not able to identify words like "melhorias"(plural) using "melhoria"(singular).

Can yo help me? I really appretiace. I didnt sleep until now hahahahaha

Em quarta-feira, 3 de setembro de 2014 21h58min34s UTC-3, vineeth mohan
escreveu:

Hello Luan ,

This is not possible.
Either you have deleted some documents.
Or there was another machine in the cluster to which the index shared
the documents.
And when the other machine went down , you lose data with it.

Hence I would recommend to add a unique name here - cluster.name ( This
is a config variable in config/elasticsearch.yml file)
If the problem persist , please paste the entire set of steps you
followed.

Thanks
Vineeth

On Thu, Sep 4, 2014 at 3:27 AM, Luan Garrido lbgar...@gmail.com wrote:

Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post,
and I did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20
documents.
After some searchs in theese, it become only 13 documents.... I really
dont know why.
Can someone help me? I just dont know what to do.

Thanks =D

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2610a7ad-3605-4695-a9a2-3213152b9db2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2610a7ad-3605-4695-a9a2-3213152b9db2%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8c07cc22-b873-4b4f-8deb-a6bbcfb74371%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #7

Does this really work?

client().admin().indices().delete(new DeleteIndexRequest("_all")).actionGet();

Was expecting something like :
client().admin().indices().delete(new DeleteIndexRequest("_all")).get();
Or
client().admin().indices().delete(new DeleteIndexRequest("_all")).execute().actionGet();

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2014 à 12:28, Luan Garrido lbgarrido89@gmail.com a écrit :

Hi, Im waiting until it happens again, because it is not every time.
I have just one pc on my cluster =D.

Can you answer others questions until this?
1- Im using JAVA API, and Im deleting index using "client().admin().indices().delete(new DeleteIndexRequest("_all")).actionGet();". This is really removing all indexes, but, when I restart ES theese index come back. I also tried to remove manually it from the directories, and nothing happened.

Last question, I promisse =D
2- Im using a brazilian analyzer to index my documents, something like this:
"local5" : {
"settings" : {
"index" : {
"uuid" : "1qCOtEZQQ4Cd6lbu-0GB5A",
"analysis" : {
"analyzer" : {
"brazilian" : {
"filter" : [ "lowercase", "brazilian_stop", "brazilian_stemmer" ],
"tokenizer" : "standard"
}
},
"filter" : {
"brazilian_stop" : {
"type" : "stop",
"stopwords" : "brazilian"
},
"brazilian_stemmer" : {
"type" : "stemmer",
"language" : "brazilian"
}
}
},
"number_of_replicas" : "1",
"number_of_shards" : "5",
"version" : {
"created" : "1030299"
}
}
}
}
And Im tring to recovever theese documents using client.prepareSearch("local5").setType("_all").setQuery(QueryBuilders.queryString(KEY+":"+VALUE)).
Im not able to identify words like "melhorias"(plural) using "melhoria"(singular).
Can yo help me? I really appretiace. I didnt sleep until now hahahahaha


Luan Barbosa Garrido

CAPGov - Centro de Apoio a Políticas de Governo
PESC / COPPE / UFRJ

Bacharel em Ciência da Computação - DCC / IM / UFRJ
Mestrando em Banco de Dados - PESC / COPPE / UFRJ

2014-09-03 21:58 GMT-03:00 vineeth mohan vm.vineethmohan@gmail.com:

Hello Luan ,

This is not possible.
Either you have deleted some documents.
Or there was another machine in the cluster to which the index shared the documents.
And when the other machine went down , you lose data with it.

Hence I would recommend to add a unique name here - cluster.name ( This is a config variable in config/elasticsearch.yml file)
If the problem persist , please paste the entire set of steps you followed.

Thanks
Vineeth

On Thu, Sep 4, 2014 at 3:27 AM, Luan Garrido lbgarrido89@gmail.com wrote:
Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post, and I did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20 documents.
After some searchs in theese, it become only 13 documents.... I really dont know why.
Can someone help me? I just dont know what to do.

Thanks =D

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/QhpNIabG2es/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGdPd5m-g7vzzqgn%2BKT7cai-L_E%3D6eisdbyPTbo8Zc5skc93WQ%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALESzpRoFf65qM_p3%3DbAo0nHXfhiY5KAS1hiHZwf7%3DbbzKn%2B3w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E20E27C9-44B4-4E42-95B9-86E1DE817AB4%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Luan Garrido) #8

Yes, It worked, but it only deleted the directories on %ES%/data/...
When I removed the others that I talk, they didnt come back.


Luan Barbosa Garrido

CAPGov - Centro de Apoio a Políticas de Governo
PESC / COPPE / UFRJ

Bacharel em Ciência da Computação - DCC / IM / UFRJ
Mestrando em Banco de Dados - PESC / COPPE / UFRJ

2014-09-05 1:44 GMT-03:00 David Pilato david@pilato.fr:

Does this really work?

client().admin().indices().delete(new
DeleteIndexRequest("_all")).actionGet();

Was expecting something like :
client().admin().indices().delete(new DeleteIndexRequest("_all")).get();
Or
client().admin().indices().delete(new
DeleteIndexRequest("_all")).execute().actionGet();

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 sept. 2014 à 12:28, Luan Garrido lbgarrido89@gmail.com a écrit :

Hi, Im waiting until it happens again, because it is not every time.
I have just one pc on my cluster =D.

Can you answer others questions until this?
1- Im using JAVA API, and Im deleting index using
"client().admin().indices().delete(new
DeleteIndexRequest("_all")).actionGet();". This is really removing all
indexes, but, when I restart ES theese index come back. I also tried to
remove manually it from the directories, and nothing happened.

Last question, I promisse =D
2- Im using a brazilian analyzer to index my documents, something like
this:

"local5" : {
"settings" : {
"index" : {
"uuid" : "1qCOtEZQQ4Cd6lbu-0GB5A",
"analysis" : {
"analyzer" : {
"brazilian" : {
"filter" : [ "lowercase", "brazilian_stop", "brazilian_stemmer" ],
"tokenizer" : "standard"
}
},
"filter" : {
"brazilian_stop" : {
"type" : "stop",
"stopwords" : "brazilian"
},
"brazilian_stemmer" : {
"type" : "stemmer",
"language" : "brazilian"
}
}
},
"number_of_replicas" : "1",
"number_of_shards" : "5",
"version" : {
"created" : "1030299"
}
}
}
}

And Im tring to recovever theese documents using client.prepareSearch("local5").setType("_all").setQuery(QueryBuilders.queryString(KEY+":"+VALUE)).

Im not able to identify words like "melhorias"(plural) using "melhoria"(singular).

Can yo help me? I really appretiace. I didnt sleep until now hahahahaha


Luan Barbosa Garrido

CAPGov - Centro de Apoio a Políticas de Governo
PESC / COPPE / UFRJ

Bacharel em Ciência da Computação - DCC / IM / UFRJ
Mestrando em Banco de Dados - PESC / COPPE / UFRJ

2014-09-03 21:58 GMT-03:00 vineeth mohan vm.vineethmohan@gmail.com:

Hello Luan ,

This is not possible.
Either you have deleted some documents.
Or there was another machine in the cluster to which the index shared the
documents.
And when the other machine went down , you lose data with it.

Hence I would recommend to add a unique name here - cluster.name ( This
is a config variable in config/elasticsearch.yml file)
If the problem persist , please paste the entire set of steps you
followed.

Thanks
Vineeth

On Thu, Sep 4, 2014 at 3:27 AM, Luan Garrido lbgarrido89@gmail.com
wrote:

Hi all,

Im new at here, and Im facing a problem.
First of all, I need to say that I took a look before send this post,
and I did not find the answer.
Im using normally elastichsearch through JAVA API, and I indexed 20
documents.
After some searchs in theese, it become only 13 documents.... I really
dont know why.
Can someone help me? I just dont know what to do.

Thanks =D

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6b0d8a31-e171-4027-acb3-491942bea782%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/QhpNIabG2es/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGdPd5m-g7vzzqgn%2BKT7cai-L_E%3D6eisdbyPTbo8Zc5skc93WQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAGdPd5m-g7vzzqgn%2BKT7cai-L_E%3D6eisdbyPTbo8Zc5skc93WQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALESzpRoFf65qM_p3%3DbAo0nHXfhiY5KAS1hiHZwf7%3DbbzKn%2B3w%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CALESzpRoFf65qM_p3%3DbAo0nHXfhiY5KAS1hiHZwf7%3DbbzKn%2B3w%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/QhpNIabG2es/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/E20E27C9-44B4-4E42-95B9-86E1DE817AB4%40pilato.fr
https://groups.google.com/d/msgid/elasticsearch/E20E27C9-44B4-4E42-95B9-86E1DE817AB4%40pilato.fr?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALESzpTAHPkzWuMoWfAnJYA41pT18b_F%2B%3DKDk92V%2BiXhwfBfNg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #9