Missing uid for nested documents

Hello,

I tried to use the most simple nested mapping according to the documentation
http://www.elasticsearch.org/guide/reference/mapping/nested-type/

but when I insert some data and try to scroll over them or try to open the index on localhost:9200 i get this error

FetchPhaseExecutionException[[posts_1000][1]: query[ConstantScore(NotDeleted(cache(PrefixFilter(_uid:default#))))],from[0],size[3000]: Fetch Failed [Failed to load uid from the index, missing internal _uid field, current fields in the doc [[]]]]

Has anyone come across this problem?

It was caused by turned-off type field index

http://www.elasticsearch.org/guide/reference/mapping/type-field/

We didn't need the type search so we had the index disabled. I do not know why it is actually bound with scrolling the nested documents, but after enabling the index, everything works as expected.

Can you share the search request and mapping that caused the error in your
first email?

On 2 August 2013 18:38, davidpilny pilny@brandembassy.com wrote:

It was caused by turned-off type field index

http://www.elasticsearch.org/guide/reference/mapping/type-field/

We didn't need the type search so we had the index disabled. I do not know
why it is actually bound with scrolling the nested documents, but after
enabling the index, everything works as expected.

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Missing-uid-for-nested-documents-tp4039035p4039042.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Sure, it was the most simple properties mapping that was possible to create.

{
"default":{
"_boost":{
"name":"_boost",
"null_value":1
},
"_type":{
"store":"no",
"index":"no"
},
"_all":{
"enabled":false
},
"properties":{
"conversations":{
"type":"nested"
}
}
}
}

And I just used a web browser search like this

http://localhost:9200/testindex/default/_search?size=3000

As soon as it came across some item that had the "conversations" field not empty, it crashed with the exception I mentioned in the first e-mail.

Which version are you running? This error only seem to exists in version
0.20 and before.

On 6 August 2013 13:06, davidpilny pilny@brandembassy.com wrote:

Sure, it was the most simple properties mapping that was possible to
create.

{
"default":{
"_boost":{
"name":"_boost",
"null_value":1
},
"_type":{
"store":"no",
"index":"no"
},
"_all":{
"enabled":false
},
"properties":{
"conversations":{
"type":"nested"
}
}
}
}

And I just used a web browser search like this

http://localhost:9200/testindex/default/_search?size=3000

As soon as it came across some item that had the "conversations" field not
empty, it crashed with the exception I mentioned in the first e-mail.

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Missing-uid-for-nested-documents-tp4039035p4039187.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.