MLT Search result is not filtered based on routing


(Pratikshya Kuinkel) #1

I have grandparent - parent - child mappings set up via routing. Normal
searching using routing information is working as expected. However, if I
provide a document id to find documents relevant to it, it does not filter
the search result based on the routing information provided. For example:
if I have two custom routings with values 111 and 666 respectively. There
are few documents for routing 111 and few for 666. When I execute mlt query
for a document in 111 with routing=111, it also shows documents in routing
666 in the search result. How can I filter it to show only documents in 111
but not in 666?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8439d58c-56ee-4635-8cf2-dc466310161c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2