"more like this" vs. mlt


(Peter Li) #1

I ran a query:

curl -XGET
"$url/ease/RadiologyResult/90642/_mlt?routing=07009409&mlt_fields=Observation.Value&min_term_freq=1&min_doc_freq=1&pretty"

It worked and returned several documents. But if I ran this:

curl -XGET "$url/ease/RadiologyResult/_search?routing=07009409&pretty" -d '
{

"query" : {
    "more_like_this" : {
        "fields": [
            "Observation.Value"
        ],
        "ids" : [ "90642" ]
   }

}
}'

It returned nothing. Is there something I am missing ?

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ffa73983-ce04-4fd3-9786-ee09d3248d83%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(vineeth mohan-2) #2

Hello Peter ,

You have set these variable for the API and not the query , that is why its
working - min_term_freq=1 , min_doc_freq=1

Thanks
Vineeth

On Thu, Jul 31, 2014 at 5:02 AM, Peter Li jenli.peter@gmail.com wrote:

I ran a query:

curl -XGET
"$url/ease/RadiologyResult/90642/_mlt?routing=07009409&mlt_fields=Observation.Value&min_term_freq=1&min_doc_freq=1&pretty"

It worked and returned several documents. But if I ran this:

curl -XGET "$url/ease/RadiologyResult/_search?routing=07009409&pretty" -d '
{

"query" : {
    "more_like_this" : {
        "fields": [
            "Observation.Value"
        ],
        "ids" : [ "90642" ]
   }

}
}'

It returned nothing. Is there something I am missing ?

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ffa73983-ce04-4fd3-9786-ee09d3248d83%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ffa73983-ce04-4fd3-9786-ee09d3248d83%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGdPd5kGyJk%3DXn%2BNRj8bKxqOgTgQ3_U1p6D%3DA%3DEqih1u2v9eYQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Peter Li) #3

Sorry, I copied and pasted the wrong query. It still didn't work with the
min* clauses in the body:

curl -XGET "$url/ease/RadiologyResult/_search?routing=07009409&pretty" -d '
{

"query" : {
    "more_like_this" : {
        "fields": [
            "Observation.Value"
        ],
        "ids" : [ "90642" ],
        "min_term_freq" : 1,
        "min_doc_freq" : 1
    }
}

}'

This returned nothing either.

On Wednesday, July 30, 2014 11:03:28 PM UTC-5, vineeth mohan wrote:

Hello Peter ,

You have set these variable for the API and not the query , that is why
its working - min_term_freq=1 , min_doc_freq=1

Thanks
Vineeth

On Thu, Jul 31, 2014 at 5:02 AM, Peter Li <jenli...@gmail.com
<javascript:>> wrote:

I ran a query:

curl -XGET
"$url/ease/RadiologyResult/90642/_mlt?routing=07009409&mlt_fields=Observation.Value&min_term_freq=1&min_doc_freq=1&pretty"

It worked and returned several documents. But if I ran this:

curl -XGET "$url/ease/RadiologyResult/_search?routing=07009409&pretty" -d
'
{

"query" : {
    "more_like_this" : {
        "fields": [
            "Observation.Value"
        ],
        "ids" : [ "90642" ]
   }

}
}'

It returned nothing. Is there something I am missing ?

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ffa73983-ce04-4fd3-9786-ee09d3248d83%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ffa73983-ce04-4fd3-9786-ee09d3248d83%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3a47fc16-cc0d-4871-8ea6-0287635fa66e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4