Multiple pipeline


(Saketh Chandra Kolisetty) #1

I am using a windows operating system.Where should i store my pipeline.yml file.i placed it in the config folder but i get an error.
This is the error i am getting:

C:\logstash-5.4.1>bin\logstash
Sending Logstash's logs to C:/logstash-5.4.1/logs which is now configured via log4j2.properties
ERROR: No configuration file was specified. Perhaps you forgot to provide the '-f yourlogstash.conf' flag?
usage:
bin/logstash -f CONFIG_PATH [-t] [-r] [] [-w COUNT] [-l LOG]
bin/logstash -e CONFIG_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]
bin/logstash --help


#2

did you uncomment content in pipeline.yml file?


(Saketh Chandra Kolisetty) #3

hi,
yes


(Vicent) #4

Add the path settings flag:

bin/logstash --path.settings="path/to/your/config/directory"

(Saketh Chandra Kolisetty) #5

hi Vicent,
I tried this but i am getting this error:

C:\logstash-5.4.1>bin\logstash --path.settings="C:\logstash-5.4.1\config\logstash.yml"
WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
An unexpected error occurred! :error => bad URI(is not URI?): file:///C:\logstash-5.4.1\config\logstash.yml/log4j2.properties, :backtrace => ["C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:176:in split'", "C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:210:inparse'", "C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:747:in parse'", "C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:994:inURI'", "C:/logstash-5.4.1/logstash-core/lib/logstash/logging/logger.rb:76:in initialize'", "org/jruby/ext/thread/Mutex.java:149:insynchronize'", "C:/logstash-5.4.1/logstash-core/lib/logstash/logging/logger.rb:74:in initialize'", "C:/logstash-5.4.1/logstash-core/lib/logstash/runner.rb:205:inexecute'", "C:/logstash-5.4.1/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in run'", "C:/logstash-5.4.1/logstash-core/lib/logstash/runner.rb:185:inrun'", "C:/logstash-5.4.1/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in run'", "C:\\logstash-5.4.1\\lib\\bootstrap\\environment.rb:71:in(root)'"]


(Saketh Chandra Kolisetty) #6

when i give the path only to the config directory this is what happens:

C:\logstash-5.4.1>bin\logstash --path.settings="C:\logstash-5.4.1\config"
An unexpected error occurred! :error => bad URI(is not URI?): file:///C:\logstash-5.4.1\config/log4j2.properties, :backtrace => ["C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:176:in split'", "C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:210:inparse'", "C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:747:in parse'", "C:/logstash-5.4.1/vendor/jruby/lib/ruby/1.9/uri/common.rb:994:inURI'", "C:/logstash-5.4.1/logstash-core/lib/logstash/logging/logger.rb:76:in initialize'", "org/jruby/ext/thread/Mutex.java:149:insynchronize'", "C:/logstash-5.4.1/logstash-core/lib/logstash/logging/logger.rb:74:in initialize'", "C:/logstash-5.4.1/logstash-core/lib/logstash/runner.rb:205:inexecute'", "C:/logstash-5.4.1/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in run'", "C:/logstash-5.4.1/logstash-core/lib/logstash/runner.rb:185:inrun'", "C:/logstash-5.4.1/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in run'", "C:\\logstash-5.4.1\\lib\\bootstrap\\environment.rb:71:in(root)'"]


(Saketh Chandra Kolisetty) #7

do i need to uncomment the logstash.yml also ?


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.