My elasticsearch.yml not loading in production cluster


(Phani Nadiminti) #1

Hi All,

I found one scenario in my prod cluster is my elasticsearch.yml configurations file not loading.
recently i updated my conf file with CORS properties when i restarted node1 in my cluster changes not effecting to cluster which is worked on beta. i entered some scrap values in my elasticsearch.yml file and restarted node in cluster .node is started successfully with out throwing any error so i came to a conclusion that my prod yml files not loading properly please help me out how to solve this issue.my linux boxes are RHEL 6.5. using /etc/sysconfig/elasticsearch file to load respective paths.

Thank & Regards,
phani


(Niraj Kumar) #2

Hi @Phani_Nadiminti,

Did you mean to say the node is not started successfully? Can you paste your yml file here also the logs.

Regards
Niraj


(Phani Nadiminti) #3

Hi niraj

Thank you for reply..problem with white spaces in configuration file.due to that cors properties defined bottom of the config file not effecting to cluster. now issue has been solved cors working fine.

Thanks,
Phani


(system) #4