My search results doesn't contain some of the documents that are present in the index

I have the following document in my index -

{
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_version" : 1,
"exists" : true, "_source" : {"type":"Characteristic Specification","name":"A-0160-0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
}

When I search for documents that starts with a*, I am not finding this
document in my search results.

http://localhost:9200/supplier/0000016920/_search?q=name:a*&pretty=true

{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.23591.11163",
"_score" : 1.0, "_source" : {"type":"Historical ATL Part","name":"A70-04-23800","revision":"","description":"ADAPTER,MPTEE","current":"History","kindof":"Part"}
} ]
}
}

Instead of the above query, if I
try http://localhost:9200/supplier/0000016920/_search?q=name:0160&pretty=true

I get the document in my result..

{
"took" : 18,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 4.091176,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_score" : 4.091176, "_source" : {"type":"Characteristic Specification","name":"A-0160-0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
} ]
}
}

I must be doing something stupid.. please tell me how to get this document
["name":"A-0160-0163-1"] in my result set.

Here is my mapping:

"0000016920" : {
  "properties" : {
    "current" : {
      "type" : "string"
    },
    "description" : {
      "type" : "string"
    },
    "kindof" : {
      "type" : "string"
    },
    "name" : {
      "type" : "string",
      "store" : "yes"
    },
    "revision" : {
      "type" : "string"
    },
    "type" : {
      "type" : "string"
    }
  }
}

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

The string A-0160-0163-1 gets tokenized by the standard analyzer as...

t = [a, 0160, 0163, 1]

At which point, 'a' is an english stopword so it's removed by the 'stop
token filter'.

http://www.elasticsearch.org/guide/reference/index-modules/analysis/stop-tokenfilter.html

On Monday, January 28, 2013 8:16:15 PM UTC-5, Mxims wrote:

I have the following document in my index -

{
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_version" : 1,
"exists" : true, "_source" : {"type":"Characteristic Specification","name":"A-0160-0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
}

When I search for documents that starts with a*, I am not finding this
document in my search results.

http://localhost:9200/supplier/0000016920/_search?q=name:a*&pretty=true

{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.23591.11163",
"_score" : 1.0, "_source" : {"type":"Historical ATL Part","name":"A70-04-23800","revision":"","description":"ADAPTER,MPTEE","current":"History","kindof":"Part"}
} ]
}
}

Instead of the above query, if I try
http://localhost:9200/supplier/0000016920/_search?q=name:0160&pretty=true

I get the document in my result..

{
"took" : 18,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 4.091176,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_score" : 4.091176, "_source" : {"type":"Characteristic Specification","name":"A-0160-0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
} ]
}
}

I must be doing something stupid.. please tell me how to get this document
["name":"A-0160-0163-1"] in my result set.

Here is my mapping:

"0000016920" : {
  "properties" : {
    "current" : {
      "type" : "string"
    },
    "description" : {
      "type" : "string"
    },
    "kindof" : {
      "type" : "string"
    },
    "name" : {
      "type" : "string",
      "store" : "yes"
    },
    "revision" : {
      "type" : "string"
    },
    "type" : {
      "type" : "string"
    }
  }
}

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Can this be solved by not analyzing this specific field, by changing my
mapping to ..

"name" : {
"type" : "string",
"index" : "not_analyzed"
},

or some other means. This is a string field that can have alpha-numeric
characters, "-". I need to make this field searchable as-is. It should not
be tokenized.

On Monday, January 28, 2013 7:58:01 PM UTC-8, egaumer wrote:

The string A-0160-0163-1 gets tokenized by the standard analyzer as...

t = [a, 0160, 0163, 1]

At which point, 'a' is an english stopword so it's removed by the 'stop
token filter'.

http://www.elasticsearch.org/guide/reference/index-modules/analysis/stop-tokenfilter.html

On Monday, January 28, 2013 8:16:15 PM UTC-5, Mxims wrote:

I have the following document in my index -

{
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_version" : 1,
"exists" : true, "_source" : {"type":"Characteristic Specification","name":"A-0160-0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
}

When I search for documents that starts with a*, I am not finding this
document in my search results.

http://localhost:9200/supplier/0000016920/_search?q=name:a*&pretty=true

{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.23591.11163",
"_score" : 1.0, "_source" : {"type":"Historical ATL Part","name":"A70-04-23800","revision":"","description":"ADAPTER,MPTEE","current":"History","kindof":"Part"}
} ]
}
}

Instead of the above query, if I try
http://localhost:9200/supplier/0000016920/_search?q=name:0160&pretty=true

I get the document in my result..

{
"took" : 18,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 4.091176,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_score" : 4.091176, "_source" : {"type":"Characteristic Specification","name":"A-0160-0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
} ]
}
}

I must be doing something stupid.. please tell me how to get this
document ["name":"A-0160-0163-1"] in my result set.

Here is my mapping:

"0000016920" : {
  "properties" : {
    "current" : {
      "type" : "string"
    },
    "description" : {
      "type" : "string"
    },
    "kindof" : {
      "type" : "string"
    },
    "name" : {
      "type" : "string",
      "store" : "yes"
    },
    "revision" : {
      "type" : "string"
    },
    "type" : {
      "type" : "string"
    }
  }
}

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Yes, you should set it to not_analyzed.

On Tue, Jan 29, 2013 at 12:53 PM, Mxims renjith.ck@gmail.com wrote:

Can this be solved by not analyzing this specific field, by changing my
mapping to ..

"name" : {
"type" : "string",
"index" : "not_analyzed"
},

or some other means. This is a string field that can have alpha-numeric
characters, "-". I need to make this field searchable as-is. It should not
be tokenized.

On Monday, January 28, 2013 7:58:01 PM UTC-8, egaumer wrote:

The string A-0160-0163-1 gets tokenized by the standard analyzer as...

t = [a, 0160, 0163, 1]

At which point, 'a' is an english stopword so it's removed by the 'stop
token filter'.

http://www.elasticsearch.org/guide/reference/index-modules/
analysis/stop-tokenfilter.htmlhttp://www.elasticsearch.org/guide/reference/index-modules/analysis/stop-tokenfilter.html

On Monday, January 28, 2013 8:16:15 PM UTC-5, Mxims wrote:

I have the following document in my index -

{
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_version" : 1,
"exists" : true, "_source" : {"type":"Characteristic Specification","name":"A-0160-**0163-1","revision":"B","**description":"Migrated from HPP PDM","current":"Approved","**kindof":"DOCUMENTS"}
}

When I search for documents that starts with a*, I am not finding this
document in my search results.

http://localhost:9200/**supplier/0000016920/_search?q=*namehttp://localhost:9200/supplier/0000016920/_search?q=name
:a
&pretty=true

{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.23591.11163",
"_score" : 1.0, "_source" : {"type":"Historical ATL Part","name":"A70-04-23800","**revision":"","description":"**ADAPTER,MPTEE","current":"**History","kindof":"Part"}
} ]
}
}

Instead of the above query, if I try http://localhost:9200/**
supplier/0000016920/_search?q=**name:0160&pretty=truehttp://localhost:9200/supplier/0000016920/_search?q=name:0160&pretty=true

I get the document in my result..

{
"took" : 18,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 4.091176,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_score" : 4.091176, "_source" : {"type":"Characteristic Specification","name":"A-0160-**0163-1","revision":"B","**description":"Migrated from HPP PDM","current":"Approved","**kindof":"DOCUMENTS"}
} ]
}
}

I must be doing something stupid.. please tell me how to get this
document ["name":"A-0160-0163-1"] in my result set.

Here is my mapping:

"0000016920" : {
  "properties" : {
    "current" : {
      "type" : "string"
    },
    "description" : {
      "type" : "string"
    },
    "kindof" : {
      "type" : "string"
    },
    "name" : {
      "type" : "string",
      "store" : "yes"
    },
    "revision" : {
      "type" : "string"
    },
    "type" : {
      "type" : "string"
    }
  }
}

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thank you Matt & Eric for your kind help.

If I make a field not_analyzed, would it cause any performance issues to
the overall search?

Thanks

On Tuesday, January 29, 2013 1:01:16 PM UTC-8, Matt Weber wrote:

Yes, you should set it to not_analyzed.

On Tue, Jan 29, 2013 at 12:53 PM, Mxims <renji...@gmail.com <javascript:>>wrote:

Can this be solved by not analyzing this specific field, by changing my
mapping to ..

"name" : {
"type" : "string",
"index" : "not_analyzed"
},

or some other means. This is a string field that can have alpha-numeric
characters, "-". I need to make this field searchable as-is. It should not
be tokenized.

On Monday, January 28, 2013 7:58:01 PM UTC-8, egaumer wrote:

The string A-0160-0163-1 gets tokenized by the standard analyzer as...

t = [a, 0160, 0163, 1]

At which point, 'a' is an english stopword so it's removed by the 'stop
token filter'.

http://www.elasticsearch.org/guide/reference/index-modules/
analysis/stop-tokenfilter.htmlhttp://www.elasticsearch.org/guide/reference/index-modules/analysis/stop-tokenfilter.html

On Monday, January 28, 2013 8:16:15 PM UTC-5, Mxims wrote:

I have the following document in my index -

{
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_version" : 1,
"exists" : true, "_source" : {"type":"Characteristic Specification","name":"A-0160-**0163-1","revision":"B","**description":"Migrated from HPP PDM","current":"Approved","**kindof":"DOCUMENTS"}
}

When I search for documents that starts with a*, I am not finding this
document in my search results.

http://localhost:9200/**supplier/0000016920/_search?q=*namehttp://localhost:9200/supplier/0000016920/_search?q=name
:a
&pretty=true

{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.23591.11163",
"_score" : 1.0, "_source" : {"type":"Historical ATL Part","name":"A70-04-23800","**revision":"","description":"**ADAPTER,MPTEE","current":"**History","kindof":"Part"}
} ]
}
}

Instead of the above query, if I try http://localhost:9200/**
supplier/0000016920/_search?q=**name:0160&pretty=truehttp://localhost:9200/supplier/0000016920/_search?q=name:0160&pretty=true

I get the document in my result..

{
"took" : 18,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 4.091176,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_score" : 4.091176, "_source" : {"type":"Characteristic Specification","name":"A-0160-**0163-1","revision":"B","**description":"Migrated from HPP PDM","current":"Approved","**kindof":"DOCUMENTS"}
} ]
}
}

I must be doing something stupid.. please tell me how to get this
document ["name":"A-0160-0163-1"] in my result set.

Here is my mapping:

"0000016920" : {
  "properties" : {
    "current" : {
      "type" : "string"
    },
    "description" : {
      "type" : "string"
    },
    "kindof" : {
      "type" : "string"
    },
    "name" : {
      "type" : "string",
      "store" : "yes"
    },
    "revision" : {
      "type" : "string"
    },
    "type" : {
      "type" : "string"
    }
  }
}

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

No, performance will not be affected.

On Tue, Jan 29, 2013 at 1:09 PM, Mxims renjith.ck@gmail.com wrote:

Thank you Matt & Eric for your kind help.

If I make a field not_analyzed, would it cause any performance issues to
the overall search?

Thanks

On Tuesday, January 29, 2013 1:01:16 PM UTC-8, Matt Weber wrote:

Yes, you should set it to not_analyzed.

On Tue, Jan 29, 2013 at 12:53 PM, Mxims renji...@gmail.com wrote:

Can this be solved by not analyzing this specific field, by changing my
mapping to ..

"name" : {
"type" : "string",
"index" : "not_analyzed"
},

or some other means. This is a string field that can have alpha-numeric
characters, "-". I need to make this field searchable as-is. It should not
be tokenized.

On Monday, January 28, 2013 7:58:01 PM UTC-8, egaumer wrote:

The string A-0160-0163-1 gets tokenized by the standard analyzer as...

t = [a, 0160, 0163, 1]

At which point, 'a' is an english stopword so it's removed by the
'stop token filter'.

http://www.elasticsearch.org/guide/reference/index-modules/a
nalysis/stop-tokenfilter.htmlhttp://www.elasticsearch.org/guide/reference/index-modules/analysis/stop-tokenfilter.html

On Monday, January 28, 2013 8:16:15 PM UTC-5, Mxims wrote:

I have the following document in my index -

{
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_version" : 1,
"exists" : true, "_source" : {"type":"Characteristic Specification","name":"A-0160-****0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
}

When I search for documents that starts with a*, I am not finding
this document in my search results.

http://localhost:9200/supplier/0000016920/_search?q=*namehttp://localhost:9200/supplier/0000016920/_search?q=name
:a
&**pretty=true

{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.23591.11163",
"_score" : 1.0, "_source" : {"type":"Historical ATL Part","name":"A70-04-23800","revision":"","description":"ADAPTER,MPTEE","current":"History","kindof":"Part"}
} ]
}
}

Instead of the above query, if I try http://localhost:9200/supp
lier/0000016920/_search?q=name:0160&pretty=truehttp://localhost:9200/supplier/0000016920/_search?q=name:0160&pretty=true

I get the document in my result..

{
"took" : 18,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 4.091176,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_score" : 4.091176, "_source" : {"type":"Characteristic Specification","name":"A-0160-****0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
} ]
}
}

I must be doing something stupid.. please tell me how to get this
document ["name":"A-0160-0163-1"] in my result set.

Here is my mapping:

"0000016920" : {
  "properties" : {
    "current" : {
      "type" : "string"
    },
    "description" : {
      "type" : "string"
    },
    "kindof" : {
      "type" : "string"
    },
    "name" : {
      "type" : "string",
      "store" : "yes"
    },
    "revision" : {
      "type" : "string"
    },
    "type" : {
      "type" : "string"
    }
  }
}

Thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thank you!

On Tuesday, January 29, 2013 1:20:53 PM UTC-8, Matt Weber wrote:

No, performance will not be affected.

On Tue, Jan 29, 2013 at 1:09 PM, Mxims <renji...@gmail.com <javascript:>>wrote:

Thank you Matt & Eric for your kind help.

If I make a field not_analyzed, would it cause any performance issues to
the overall search?

Thanks

On Tuesday, January 29, 2013 1:01:16 PM UTC-8, Matt Weber wrote:

Yes, you should set it to not_analyzed.

On Tue, Jan 29, 2013 at 12:53 PM, Mxims renji...@gmail.com wrote:

Can this be solved by not analyzing this specific field, by changing my
mapping to ..

"name" : {
"type" : "string",
"index" : "not_analyzed"
},

or some other means. This is a string field that can have alpha-numeric
characters, "-". I need to make this field searchable as-is. It should not
be tokenized.

On Monday, January 28, 2013 7:58:01 PM UTC-8, egaumer wrote:

The string A-0160-0163-1 gets tokenized by the standard analyzer as...

t = [a, 0160, 0163, 1]

At which point, 'a' is an english stopword so it's removed by the
'stop token filter'.

http://www.elasticsearch.org/guide/reference/index-modules/a
nalysis/stop-tokenfilter.htmlhttp://www.elasticsearch.org/guide/reference/index-modules/analysis/stop-tokenfilter.html

On Monday, January 28, 2013 8:16:15 PM UTC-5, Mxims wrote:

I have the following document in my index -

{
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_version" : 1,
"exists" : true, "_source" : {"type":"Characteristic Specification","name":"A-0160-****0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
}

When I search for documents that starts with a*, I am not finding
this document in my search results.

http://localhost:9200/supplier/0000016920/_search?q=*namehttp://localhost:9200/supplier/0000016920/_search?q=name
:a
&**pretty=true

{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.23591.11163",
"_score" : 1.0, "_source" : {"type":"Historical ATL Part","name":"A70-04-23800","revision":"","description":"ADAPTER,MPTEE","current":"History","kindof":"Part"}
} ]
}
}

Instead of the above query, if I try http://localhost:9200/supp
lier/0000016920/_search?q=name:0160&pretty=truehttp://localhost:9200/supplier/0000016920/_search?q=name:0160&pretty=true

I get the document in my result..

{
"took" : 18,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 4.091176,
"hits" : [ {
"_index" : "supplier",
"_type" : "0000016920",
"_id" : "37053.5138.32768.19768",
"_score" : 4.091176, "_source" : {"type":"Characteristic Specification","name":"A-0160-****0163-1","revision":"B","description":"Migrated from HPP PDM","current":"Approved","kindof":"DOCUMENTS"}
} ]
}
}

I must be doing something stupid.. please tell me how to get this
document ["name":"A-0160-0163-1"] in my result set.

Here is my mapping:

"0000016920" : {
  "properties" : {
    "current" : {
      "type" : "string"
    },
    "description" : {
      "type" : "string"
    },
    "kindof" : {
      "type" : "string"
    },
    "name" : {
      "type" : "string",
      "store" : "yes"
    },
    "revision" : {
      "type" : "string"
    },
    "type" : {
      "type" : "string"
    }
  }
}

Thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.