Nested filter returns 0 results


(Andra Bennett) #1

Hello,

I have the following document:

someemail@email.com

I index the above document relying on dynamic mappings.

First I set an initial mapping as :

{
"index1" :
{
"date_detection":false,
"properties":
{
"basic":
{
"type": nested
}
}
}
}

I try to search for this document using the following nested filter:

NestedFilterBuilder filterBasic = new NestedFilterBuilder("basic",
QueryBuilders.fieldQuery("basic.content", "someemail@email.com"))

When I print out the mappings (after indexing) I get the following:

{"requests":{"date_detection":false,"properties":{"basic":{"type":"nested","properties":{"contact":{"type":"string"}}}}}}

I get no results (with elastic search v. 0.90.0).

Is the filter incorrect for the mapping provided?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f3dff12b-a40b-4e87-add6-70ee13c4d8c1%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(John Ohno) #2

Are you sure you don't want to be using:

NestedFilterBuilder filterBasic = new NestedFilterBuilder("basic",
QueryBuilders.fieldQuery("basic.contact", "some...@email.com"))

On Monday, February 3, 2014 12:10:09 PM UTC-5, Andra Bennett wrote:

Hello,

I have the following document:

some...@email.com <javascript:>

I index the above document relying on dynamic mappings.

First I set an initial mapping as :

{
"index1" :
{
"date_detection":false,
"properties":
{
"basic":
{
"type": nested
}
}
}
}

I try to search for this document using the following nested filter:

NestedFilterBuilder filterBasic = new NestedFilterBuilder("basic",
QueryBuilders.fieldQuery("basic.content", "some...@email.com <javascript:>
"))

When I print out the mappings (after indexing) I get the following:

{"requests":{"date_detection":false,"properties":{"basic":{"type":"nested","properties":{"contact":{"type":"string"}}}}}}

I get no results (with elastic search v. 0.90.0).

Is the filter incorrect for the mapping provided?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/10b05d8e-699d-4dd0-b31a-51e4ec8cf10e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Andra Bennett) #3

Same issue with the nested filter - returns no results.

I actually played around with removing the nested type from the mapping,
and that's how I got to write the plain filter

On Monday, February 3, 2014 12:10:09 PM UTC-5, Andra Bennett wrote:

Hello,

I have the following document:

someemail@email.com

I index the above document relying on dynamic mappings.

First I set an initial mapping as :

{
"index1" :
{
"date_detection":false,
"properties":
{
"basic":
{
"type": nested
}
}
}
}

I try to search for this document using the following nested filter:

NestedFilterBuilder filterBasic = new NestedFilterBuilder("basic",
QueryBuilders.fieldQuery("basic.content", "someemail@email.com"))

When I print out the mappings (after indexing) I get the following:

{"requests":{"date_detection":false,"properties":{"basic":{"type":"nested","properties":{"contact":{"type":"string"}}}}}}

I get no results (with elastic search v. 0.90.0).

Is the filter incorrect for the mapping provided?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4a642321-2925-4b90-a4d1-0348422171c9%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4