Nested Json throws error "can't merge a non object mapping [field] with an object mapping [field]"


I have a nested json dataset of 2 layers which consist of around 1300 fields in the second layer. I am getting the below error for some fields

type => illegal_argument_exception
reason => can't merge a non object mapping [field] with an object mapping [field]

Observations I found so far:
1] When I tried to remove the field with error, the error starts coming for some other field randomly (mostly with boolean or integer data type)
2] When I tried to remove all the nested fields using remove_field filter, except the one comes with error, it is getting parsed.

I am sorry I cannot share the data as it is confidential, please find the below config file which I use

file {
path => "C:/Users/suresh/Documents/logs/*"
sincedb_path => C:\Users\suresh\Documents\sincedb_path_dev"
codec => "json"
start_position => beginning

elasticsearch {
action => "index"
hosts => "localhost:9200"
index => "logs-dev-%{+yyyy-MM-dd}"

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.