Netscaler pattern works in test config but not live


(Stefan Midjich) #1

The following test configuration works when I paste this data to stdin:
<134>May 20 23:35:25 vm-server01 05/20/2014:21:35:25 GMT server01 0-PPE-0 : TCP CONN_TERMINATE 809689 0 : Source 127.0.0.1:7776 - Destination 127.0.0.2:59919 - Start Time 05/20/2014:21:34:42 GMT - End Time 05/20/2014:21:35:25 GMT - Total_bytes_send 1 - Total_bytes_recv 1

See attached file logstash_test.conf

And the pattern is exactly the same in both test and production.

See attached file netscaler.grok

Yet this live config refuses to parse netscaler logs being sent via syslog.

See attached file logstash.conf

So I assume I'm missing something with the config or the way I'm pasting the log data into stdin, because the pattern works. I just cannot figure it out. Can anyone please help?

The logstash_test.conf is actually a scaled down version of logstash.conf, I just started removing things from it and eventually it worked. But I can't figure out what I am doing wrong.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dea05333-a4e8-4ecb-98d1-4994dd21da8b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Stefan Midjich) #2

I have now tried logstash 1.4.1 and this time I just edited the inputs to
replace syslog with stdin, and added stdout with rubydebug codec to the
outputs. If I paste the netscaler log line into stdin it works, it even
inserts into elasticsearch in a proper format.

But any other log being sent from the netscaler is left unformatted.

2014-05-21 10:43 GMT+02:00 Stefan Midjich stefan.midjich@gmail.com:

The following test configuration works when I paste this data to stdin:
<134>May 20 23:35:25 vm-server01 05/20/2014:21:35:25 GMT server01 0-PPE-0 : TCP CONN_TERMINATE 809689 0 : Source 127.0.0.1:7776 - Destination 127.0.0.2:59919 - Start Time 05/20/2014:21:34:42 GMT - End Time 05/20/2014:21:35:25 GMT - Total_bytes_send 1 - Total_bytes_recv 1

See attached file logstash_test.conf

And the pattern is exactly the same in both test and production.

See attached file netscaler.grok

Yet this live config refuses to parse netscaler logs being sent via syslog.

See attached file logstash.conf

So I assume I'm missing something with the config or the way I'm pasting the log data into stdin, because the pattern works. I just cannot figure it out. Can anyone please help?

The logstash_test.conf is actually a scaled down version of logstash.conf, I just started removing things from it and eventually it worked. But I can't figure out what I am doing wrong.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/WG6SPf3FTFk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/dea05333-a4e8-4ecb-98d1-4994dd21da8b%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/dea05333-a4e8-4ecb-98d1-4994dd21da8b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--

Med vänliga hälsningar / With kind regards

Stefan Midjich
http://swehack.se/

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAM08UfPw2K4bDokWTcC90tb4NuyAPNyK3ZwWY5ExBbK3Prt5cg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3