I'm running ES 5.4.1 with the transport client library. I'm running into a dependency issue and below is the error:
I did a mvn dependency tree and found the ES depends on both Netty3 and Netty4. I tried to exclude one but to no avail as ES needed the dependency. Does anyone know what's the way around it ?
I had a similar problem and in my case, I used non-matched dependencies:
The fix was to use org.Elasticsearch.client 5.4.1
I have the same versions of ES i.e. 5.4.1
I am running in the same issue. Can someone please help?
This is not a problem, Netty 3 and Netty 4 use completely different package names so there is no possibility of conflict.
Thanks for the response jason. Do you have any idea what else could cause that exception?
I think that you have an older version of Netty 4 on your classpath (maybe you accidentally included 4.0.11.Final or you have another dependency that depends on an older version of 4.0.x.Final of Netty? I say this because that method (
io.netty.buffer.CompositeByteBuf io.netty.buffer.CompositeByteBuf#addComponents(boolean, java.lang.Iterable)) has existed through the life of the 4.1.x.Final series of Netty but not always in 4.0.x.Final. If you have an older 4.0.x.Final on the classpath then you can see exactly this error. Double check your dependencies and ensure that you have the right version and not a second version (explicitly or transitively).
These are all the netty jars in the classpath of my project.
find lib/ -iname "netty"
both versions were brought in by ElasticSearch itself. I don't have any explicit dependency on netty.
This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.