Network.publish_host=_ppp0_ doesn't work


(Michal Ochman) #1

Hi,

I'm trying to force ElasticSearch embedded Java node client to use ppp0
interface instead of providing IP address (because it changes), but somehow
it doesn't work. That interface is discovered during the startup but later
ES still uses eth0 IP address.

ppp0 display_name [ppp0]

    address [/10.7.7.201] 
    mtu [1446] multicast [true] ptp [true] loopback [false] up [true] 

virtual [false]
eth0 display_name [eth0]
address [/fe80:0:0:0:215:17ff:feac:5724%2] [/192.168.1.3]
mtu [1500] multicast [true] ptp [false] loopback [false] up [true]
virtual [false]
lo display_name [lo]
address [/0:0:0:0:0:0:0:1%1] [/127.0.0.1]
mtu [65536] multicast [false] ptp [false] loopback [true] up
[true] virtual [false]

and later in the log:

[SuperPro] bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address

{inet[/192.168.1.3:9300]}

When ppp0 IP address is set then everything works just fine
(network.publish_host=10.7.7.201). Any ideas what may be wrong?

Additional info:
OS: Ubuntu 12.04.3
Java: 7u25 and 7u51
ElasticSearch: 0.90.9 and 0.90.11

Thank you,
Michal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8ec1aa82-ceea-49db-b746-76688c1aab84%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Michal Ochman) #2

Ok, it worked for me when I set network.publish_host=ppp0:ipv4. In my
case ppp0 doesn't have any IPv6 address, but it looks like ES needs that
additional option to use the interface.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/beafc60f-bebc-407d-8cd2-6b3dacc1b3b4%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3