New ICU plugin version is not available?


(Barsk) #1
Hi!




I made a contribution to the ICU plugin, the unicodeSetFilter
attribute that enables filtered asciiFolding (<a href="https://github.com/elasticsearch/elasticsearch-analysis-icu/pull/3">https://github.com/elasticsearch/elasticsearch-analysis-icu/pull/3</a>).
It is merged into the <a href="http://www.elasticsearch.org/guide/reference/index-modules/analysis/icu-plugin.html">docs
</a>and available as source in master. But no downloadable package?
The latest 1.2.0 plugin package seems to not include this
contribution. I guess a 1.3.0 version needs to be created so it can
be installed as a plugin properly?
/Kristian

(Shay Banon) #2

Yes, we need to release 1.3.0 version. Can you open an issue on the relevant repo (just so it won't get lost)?

On Tuesday, March 13, 2012 at 5:28 PM, Kristian Jörg wrote:

Hi!

I made a contribution to the ICU plugin, the unicodeSetFilter attribute that enables filtered asciiFolding (https://github.com/elasticsearch/elasticsearch-analysis-icu/pull/3). It is merged into the docs (http://www.elasticsearch.org/guide/reference/index-modules/analysis/icu-plugin.html)and available as source in master. But no downloadable package? The latest 1.2.0 plugin package seems to not include this contribution. I guess a 1.3.0 version needs to be created so it can be installed as a plugin properly?
/Kristian


(Barsk) #3
Done.




Shay Banon skrev 2012-03-14 13:16:
<blockquote cite="mid:EA060822FACF461D9762148C7BC89756@gmail.com" type="cite"> Yes, we need to release 1.3.0 version. Can you open an issue
    on the relevant repo (just so it won't get lost)? 

On Tuesday, March 13, 2012 at 5:28 PM, Kristian Jörg wrote:

Hi!
          I made a contribution to the ICU plugin, the
          unicodeSetFilter attribute that enables filtered
          asciiFolding (<a moz-do-not-send="true" href="https://github.com/elasticsearch/elasticsearch-analysis-icu/pull/3">https://github.com/elasticsearch/elasticsearch-analysis-icu/pull/3</a>).

          It is merged into the <a moz-do-not-send="true" href="http://www.elasticsearch.org/guide/reference/index-modules/analysis/icu-plugin.html">docs

          </a>and available as source in master. But no downloadable
          package? The latest 1.2.0 plugin package seems to not
          include this contribution. I guess a 1.3.0 version needs
          to be created so it can be installed as a plugin properly?
/Kristian
-- 
Med vänlig hälsning
Kristian Jörg

Devo IT AB
Tel: 054 - 22 14 58, 0709 - 15 83 42
E-post: kristian.jorg@devo.se
Webb: http://www.devo.se

(system) #4