New index not appearing in kibana


(Kumar Deepankar) #1

Hi,

I have created index in elastic search through PIG.
The new index is not appearing in Kibana Discover section for search.
But I can see the index in elastic search.

Please help how to fix this.

Thanks


(Thomas Neirynck) #2

@deepankar32

You'll probably need to create your index pattern first. This is a mapping from Kibana to your Elasticsearch index. Go to Management > Index Pattern > Add New

I'd suggest to go through the Getting Started section of Kibana. There's a section that shows you how to create an index pattern. https://www.elastic.co/guide/en/kibana/current/tutorial-define-index.html


(Kumar Deepankar) #3

Thanks.
Now if we don't have any time stamp in documents that we are indexing than how we can create index pattern in Kibana. Please suggest.


(Thomas Neirynck) #4

That's fine. You can create an index without timestamp. You will not have that combobox option.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.