New Install on small box - OOME with no data loaded?!


(Tony Su) #1

Running in a VMware VM

ES 1.3 from the official repo
On an openSUSE box using the CentOS RPM as follows

zypper ar http://packages.elasticsearch.org/elasticsearch/1.3/centos Elasticsearch_1.3_repository

openJDK 1.7

# systemctl status
elasticsearch.service - Starts and stops a single elasticsearch instance on
this system
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled)
Active: failed (Result: resources) since Fri 2014-08-01 08:15:32 PDT;
1min 40s ago
Docs: http://www.elasticsearch.org
Process: 2047 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -d -p
/var/run/elasticsearch/elasticsearch.pid -Des.default.config=$CONF_FILE
-Des.default.path.home=$ES_HOME -Des.default.path.logs=$LOG_DIR
-Des.default.path.data=$DATA_DIR -Des.default.path.work=$WORK_DIR
-Des.default.path.conf=$CONF_DIR (code=exited, status=0/SUCCESS)

Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: Starting Starts and stops a
single elasticsearch instance on this system...
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: PID file
/var/run/elasticsearch/elasticsearch.pid not readable (yet?) after start.
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: elasticsearch.service never
wrote its PID file. Failing.
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: Failed to start Starts and
stops a single elasticsearch instance on this system.
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: Unit elasticsearch.service
entered failed state.

Syslog errors
# cat /var/log/messages | grep elasticsearch
2014-08-01T08:15:32.526408-07:00 OPENSUSE-SERVER elasticsearch[2047]: Can't
start up: not enough memory
2014-08-01T08:15:32.528386-07:00 OPENSUSE-SERVER systemd[1]:
elasticsearch.service never wrote its PID file. Failing.
2014-08-01T08:15:32.528718-07:00 OPENSUSE-SERVER systemd[1]: Failed to
start Starts and stops a single elasticsearch instance on this system.
2014-08-01T08:15:32.528909-07:00 OPENSUSE-SERVER systemd[1]: Unit
elasticsearch.service entered failed state.

I've re-configured the VM with 1GB, 2GB and 8GB RAM with the exact same
errors. Is there a known absolutely minimum RAM requirement?
The exact same install procedure from official repos didn't have a problem
with ES 1.0, installed, configured and running with as little as 1GB RAM
(but usually running with more)
Has something drastic changed between 1.0 and 1.3?
Or, maybe when ES is installed it reads available RAM and does not auto
update the next time it restarts?

BTW - I have ES running in a Dockerized openSUSE, I guess I'll have to
check whether it's installing latest ES (would be expected) although with
no elasticsearch.yml. Before relying on that entirely, I'd like to
understand why installing from repo is failing this way.

Thx,
Tony

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c0c3c2fc-babc-4301-9e6b-16d20ba3663c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Tony Su) #2

Resolved the problem.
Although openJDK1.7 was installed, for some reason the system was
configured with openJDK 1.5.
Installed Oracle SE JDK 1.7 and no problems.

Tony

On Friday, August 1, 2014 8:40:02 AM UTC-7, Tony Su wrote:

Running in a VMware VM

ES 1.3 from the official repo
On an openSUSE box using the CentOS RPM as follows

zypper ar http://packages.elasticsearch.org/elasticsearch/1.3/centos Elasticsearch_1.3_repository

openJDK 1.7

# systemctl status
elasticsearch.service - Starts and stops a single elasticsearch instance
on this system
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled)
Active: failed (Result: resources) since Fri 2014-08-01 08:15:32 PDT;
1min 40s ago
Docs: http://www.elasticsearch.org
Process: 2047 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -d -p
/var/run/elasticsearch/elasticsearch.pid -Des.default.config=$CONF_FILE
-Des.default.path.home=$ES_HOME -Des.default.path.logs=$LOG_DIR
-Des.default.path.data=$DATA_DIR -Des.default.path.work=$WORK_DIR
-Des.default.path.conf=$CONF_DIR (code=exited, status=0/SUCCESS)

Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: Starting Starts and stops a
single elasticsearch instance on this system...
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: PID file
/var/run/elasticsearch/elasticsearch.pid not readable (yet?) after start.
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: elasticsearch.service never
wrote its PID file. Failing.
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: Failed to start Starts and
stops a single elasticsearch instance on this system.
Aug 01 08:15:32 OPENSUSE-SERVER systemd[1]: Unit elasticsearch.service
entered failed state.

Syslog errors
# cat /var/log/messages | grep elasticsearch
2014-08-01T08:15:32.526408-07:00 OPENSUSE-SERVER elasticsearch[2047]:
Can't start up: not enough memory
2014-08-01T08:15:32.528386-07:00 OPENSUSE-SERVER systemd[1]:
elasticsearch.service never wrote its PID file. Failing.
2014-08-01T08:15:32.528718-07:00 OPENSUSE-SERVER systemd[1]: Failed to
start Starts and stops a single elasticsearch instance on this system.
2014-08-01T08:15:32.528909-07:00 OPENSUSE-SERVER systemd[1]: Unit
elasticsearch.service entered failed state.

I've re-configured the VM with 1GB, 2GB and 8GB RAM with the exact same
errors. Is there a known absolutely minimum RAM requirement?
The exact same install procedure from official repos didn't have a problem
with ES 1.0, installed, configured and running with as little as 1GB RAM
(but usually running with more)
Has something drastic changed between 1.0 and 1.3?
Or, maybe when ES is installed it reads available RAM and does not auto
update the next time it restarts?

BTW - I have ES running in a Dockerized openSUSE, I guess I'll have to
check whether it's installing latest ES (would be expected) although with
no elasticsearch.yml. Before relying on that entirely, I'd like to
understand why installing from repo is failing this way.

Thx,
Tony

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/978331e7-da68-4044-b8b7-cf0c3355e4fd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3