Nginx SSL config


#1

The nginx docker image I am using sends everything to https which causes metricbeat to print out the following logs in elasticsearch error making http request: Get https://ui:443/server-status: x509: failed to load system roots and no roots provided. Is there a way to set up ssl config in metricbeat.yml?


(Andrew Kroh) #2

The module supports the same ssl options that you'll see in the output configuration. So for example:

metricbeat.modules:
- module: nginx
  metricsets: [stubstatus]
  ssl.certificate_authorities:
  - /etc/tls/my-ca.pem

https://www.elastic.co/guide/en/beats/metricbeat/5.6/configuration-output-ssl.html#_ssl_options


#3

Sorry didnt notice that in the documentation this can be closed :grinning:


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.