No error for permission if symlinks involved in paths for filebeat


(Rajeev Ranjan) #1

I tried to run filebeat to monitor a path that involved a symlink.

    symlink:  /var/log/current -> /var/log/version1
    paths:  /var/log/current/logs/abc.log
    Actual file location: /var/log/version1/logs/abc.log

The file names and paths are only indicative and not actual.
There were permission issues(read permission was not there on the actual path but on symlink path) with the symlink but filebeat did not throw any error.

Is this by design or a bug?


(Andrew Kroh) #2

Did you enable symlinks for the prospector?


(Rajeev Ranjan) #3

Yes, I had it enabled.
I tried accessing the files from the concerned user, when I discovered that there were issues with the permission. After i gave the appropriate permissions, I was able to harvest the logs with the exact same yml configuration for filebeat.


(Andrew Kroh) #4

Ok, good I wanted to make sure we had the basics covered.

Probably the best people to answer this question are either @ruflin or @kvch.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.