No mapping found error for geo_distance sorting


(Travis Bullock) #1

Hello,

I've set up a mapping on myIndex as follows:

"mappings" : {
"place" : {
"properties" : {
"location" : {
"type" : "geo_point",
"fielddata" : {
"format" : "compressed",
"precision" : "3m"
}
}
}
}
}

And indexed data like so:

{"_index":"myIndex","_type":"place","_id":"328","_version":2,"exists":true, "_source" : {"location":{"lat":42.02397,"lon":-87.684965}}

When querying I get an error:

{
"index": "myIndex",
"size": 10,
"from": 1,
"type": "place",
"filtered": {
"query": {
"query_string": "test"
},
"bool": {
"must": [
{
"geo_distance": {
"distance": "150mi",
"place.location": {
"lat": "41.8781136",
"lon": "-87.6297982"
}
}
}
]
}
},
"sort": [
{
"geo_distance": {
"location": {
"lat": "41.8781136",
"lon": "-87.6297982"
},
"unit": "mi",
"order": "ASC"
}
}
]
}

The error is "Parse Failure [No mapping found for [[object Object]] in order to sort on"

I've tried changing location to place.location in the sort.

Also, should I use "_geo_distance" or "geo_distance"? Why are they both used in different documentation?

Thanks!

Travis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/452ec200-001d-4347-b756-6350b281d59c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

See doc: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-sort.html#_geo_distance_sorting

Missing _ I guess

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 16 janvier 2014 at 18:21:24, Travis Bullock (travisrbullock@gmail.com) a écrit:

Hello,

I've set up a mapping on myIndex as follows:

"mappings" : {
"place" : {
"properties" : {
"location" : {
"type" : "geo_point",
"fielddata" : {
"format" : "compressed",
"precision" : "3m"
}
}
}
}
}

And indexed data like so:

{"_index":"myIndex","_type":"place","_id":"328","_version":2,"exists":true, "_source" : {"location":{"lat":42.02397,"lon":-87.684965}}

When querying I get an error:

{
"index": "myIndex",
"size": 10,
"from": 1,
"type": "place",
"filtered": {
"query": {
"query_string": "test"
},
"bool": {
"must": [
{
"geo_distance": {
"distance": "150mi",
"place.location": {
"lat": "41.8781136",
"lon": "-87.6297982"
}
}
}
]
}
},
"sort": [
{
"geo_distance": {
"location": {
"lat": "41.8781136",
"lon": "-87.6297982"
},
"unit": "mi",
"order": "ASC"
}
}
]
}

The error is "Parse Failure [No mapping found for [[object Object]] in order to sort on"

I've tried changing location to place.location in the sort.
Also, should I use "_geo_distance" or "geo_distance"? Why are they both used in different documentation?

Thanks!
Travis

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/452ec200-001d-4347-b756-6350b281d59c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52d81774.4e6afb66.dc5%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Travis Bullock) #3

Thanks, I already tried that with no luck.

On Thursday, January 16, 2014 11:31:32 AM UTC-6, David Pilato wrote:

See doc:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-sort.html#_geo_distance_sorting

Missing _ I guess

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 16 janvier 2014 at 18:21:24, Travis Bullock (travisr...@gmail.com<javascript:>)
a écrit:

Hello,

I've set up a mapping on myIndex as follows:

"mappings" : {
"place" : {
"properties" : {
"location" : {
"type" : "geo_point",
"fielddata" : {
"format" : "compressed",
"precision" : "3m"
}
}
}
}
}

And indexed data like so:

{"_index":"myIndex","_type":"place","_id":"328","_version":2,"exists":true, "_source" : {"location":{"lat":42.02397,"lon":-87.684965}}

When querying I get an error:

{
"index": "myIndex",
"size": 10,
"from": 1,
"type": "place",
"filtered": {
"query": {
"query_string": "test"
},
"bool": {
"must": [
{
"geo_distance": {
"distance": "150mi",
"place.location": {
"lat": "41.8781136",
"lon": "-87.6297982"
}
}
}
]
}
},
"sort": [
{
"geo_distance": {
"location": {
"lat": "41.8781136",
"lon": "-87.6297982"
},
"unit": "mi",
"order": "ASC"
}
}
]
}

The error is "Parse Failure [No mapping found for [[object Object]] in order to sort on"

I've tried changing location to place.location in the sort.

Also, should I use "_geo_distance" or "geo_distance"? Why are they both used in different documentation?

Thanks!

Travis

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/452ec200-001d-4347-b756-6350b281d59c%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/31154fe7-e730-4147-946a-e8f8c2912949%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

Could you reproduce it with a curl recreation as explained here? http://www.elasticsearch.org/help/

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 16 janvier 2014 at 18:40:12, Travis Bullock (travisrbullock@gmail.com) a écrit:

Thanks, I already tried that with no luck.

On Thursday, January 16, 2014 11:31:32 AM UTC-6, David Pilato wrote:
See doc: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-sort.html#_geo_distance_sorting

Missing _ I guess

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 16 janvier 2014 at 18:21:24, Travis Bullock (travisr...@gmail.com) a écrit:

Hello,

I've set up a mapping on myIndex as follows:

"mappings" : {
"place" : {
"properties" : {
"location" : {
"type" : "geo_point",
"fielddata" : {
"format" : "compressed",
"precision" : "3m"
}
}
}
}
}

And indexed data like so:

{"_index":"myIndex","_type":"place","_id":"328","_version":2,"exists":true, "_source" : {"location":{"lat":42.02397,"lon":-87.684965}}

When querying I get an error:

{
"index": "myIndex",
"size": 10,
"from": 1,
"type": "place",
"filtered": {
"query": {
"query_string": "test"
},
"bool": {
"must": [
{
"geo_distance": {
"distance": "150mi",
"place.location": {
"lat": "41.8781136",
"lon": "-87.6297982"
}
}
}
]
}
},
"sort": [
{
"geo_distance": {
"location": {
"lat": "41.8781136",
"lon": "-87.6297982"
},
"unit": "mi",
"order": "ASC"
}
}
]
}

The error is "Parse Failure [No mapping found for [[object Object]] in order to sort on"

I've tried changing location to place.location in the sort.
Also, should I use "_geo_distance" or "geo_distance"? Why are they both used in different documentation?

Thanks!
Travis

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/452ec200-001d-4347-b756-6350b281d59c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/31154fe7-e730-4147-946a-e8f8c2912949%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52d81c45.3f2dba31.dc5%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Travis Bullock) #5

Thanks again. By working with a gist I figured out the problem was with how
I'm using the javascript client. The sort wasn't in the "body" of my json
request.

On Thursday, January 16, 2014 11:52:05 AM UTC-6, David Pilato wrote:

Could you reproduce it with a curl recreation as explained here?
http://www.elasticsearch.org/help/

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 16 janvier 2014 at 18:40:12, Travis Bullock (travisr...@gmail.com<javascript:>)
a écrit:

Thanks, I already tried that with no luck.

On Thursday, January 16, 2014 11:31:32 AM UTC-6, David Pilato wrote:

See doc:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-sort.html#_geo_distance_sorting

Missing _ I guess

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 16 janvier 2014 at 18:21:24, Travis Bullock (travisr...@gmail.com) a
écrit:

Hello,

I've set up a mapping on myIndex as follows:

"mappings" : {
"place" : {
"properties" : {
"location" : {
"type" : "geo_point",
"fielddata" : {
"format" : "compressed",
"precision" : "3m"
}
}
}
}
}

And indexed data like so:

{"_index":"myIndex","_type":"place","_id":"328","_version":2,"exists":true, "_source" : {"location":{"lat":42.02397,"lon":-87.684965}}

When querying I get an error:

{
"index": "myIndex",
"size": 10,
"from": 1,
"type": "place",
"filtered": {
"query": {
"query_string": "test"
},
"bool": {
"must": [
{
"geo_distance": {
"distance": "150mi",
"place.location": {
"lat": "41.8781136",
"lon": "-87.6297982"
}
}
}
]
}
},
"sort": [
{
"geo_distance": {
"location": {
"lat": "41.8781136",
"lon": "-87.6297982"
},
"unit": "mi",
"order": "ASC"
}
}
]
}

The error is "Parse Failure [No mapping found for [[object Object]] in order to sort on"

I've tried changing location to place.location in the sort.

Also, should I use "_geo_distance" or "geo_distance"? Why are they both used in different documentation?

Thanks!

Travis

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/452ec200-001d-4347-b756-6350b281d59c%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/31154fe7-e730-4147-946a-e8f8c2912949%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/05a4cff7-596e-4a64-9e40-acd1163df983%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6