No matching indices found: No indices match pattern "winlogbeat-*"

Hello ,
So i installed winlogbeat as a service and it is running fine, when i check in Kibana i get that error:
No matching indices found: No indices match pattern "winlogbeat-*"
-Logsash was configured to receive data from Filebeat and Winlogbeat.
-Winlogbeat output is configured to Logstash and i commented the elastic output.
-Logstash was configured to recieve data from port 5044.
Here is the winlogbeat configuration:

#-------------------------- Elasticsearch output ------------------------------
  # Array of hosts to connect to.
  #hosts: ["localhost:9200"]
#----------------------------- Logstash output --------------------------------
  # The Logstash hosts
  hosts: ["localhost:5044"]

Here is the Logstash configuration:

input {
 beats {
port => 5044

Please note that i'm using a grok filter that is working fine with parsing data received from filebeat.
Any help will be apperciated.

Can you provide more details about how your Logstash is configured. You should also configure output Logstash -> ElasticSearch

Please see this page Configuring input beats to see the example of output config.

@Michal_Pristas hello Michal thanks for the quick response. yes it was done and note that it had worked fine with filebeat. here is the logstash configuration :

output {
elasticsearch {
hosts => "localhost:9200"
manage_template => false
index => "%{[@metadata][beat]}-%{+YYYY.MM}"
document_type => "%{[@metadata][type]}"

please let me know if i could provide you with more info about the configuration or logs.

The problem was solved, my mistake, the grok filter was dropping down the lines coming from winlogbeat (the "if grokparse_failure drop" condition). Now it is working fine . Thanks @Michal_Pristas

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.