No paths were defined for prospector accessing config


(Arnaud Giffard) #1

Hi,

I try the Quick Start guide for Filebeat (https://www.elastic.co/guide/en/beats/filebeat/6.1/filebeat-modules-quickstart.html#setting-variables) but I encounter a problem when I launch the folloing command :
.\filebeat.exe -v -d "*" -modules system

I obtain the following error :frowning_face:

CRIT Exiting: Error in initing prospector: No paths were defined for prospector accessing config

I check my configuration file filebeat.yml and it seems correct.

Thanks for your help.

Arnaud


(Arnaud Giffard) #2

filebeat.prospectors:

  • type: log
    • C:\Users\agiffard\elasticsearch-6.1.1\logs*.log

(ruflin) #3

It seems you are missing a paths part https://www.elastic.co/guide/en/beats/filebeat/6.1/filebeat-configuration.html? Please post your config with ticks around so it's formatted correctly.

Note: The getting started guide you linked is for modules.


(Arnaud Giffard) #4

filebeat.prospectors:

  • type: log
    enabled: true
    paths:
    • C:\Users\agiffard\elasticsearch-6.1.1\logs*.log

(Arnaud Giffard) #5

Yes, I made a mistake when I copy my configuration file.


(Arnaud Giffard) #6

Okay, I'm getting started on Filebeat, you want to say Filebeat works without work on modules ?


(ruflin) #7

Yes, you can either use modules which are config options which work out of the box or create your own prospectors.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.