No such index [.ds-.fleet-actions-results-*]

Can't modify settings for these indicies via Dev Tool or UI and the data stream doesn't have a delete action.

PUT /.ds-.fleet-actions-results-*/_settings
{
  "index" : {
    "number_of_replicas" : 0
  }
}
{
  "error" : {
    "root_cause" : [
      {
        "type" : "index_not_found_exception",
        "reason" : "no such index [.ds-.fleet-actions-results-*]",
        "index_uuid" : "_na_",
        "index" : ".ds-.fleet-actions-results-*"
      }
    ],
    "type" : "index_not_found_exception",
    "reason" : "no such index [.ds-.fleet-actions-results-*]",
    "index_uuid" : "_na_",
    "index" : ".ds-.fleet-actions-results-*"
  },
  "status" : 404
}


I am having this same issue. I only have 1 Elasticsearch node, so having any replicas at all causes my health to go yellow. And because of this, I believe ILM is not working properly.

Anyone have a solution to assigning the system index ".ds-.fleet-actions-results" to 0 replicas?

I posted about this too, when I try to manually change for a single index

curl -XPUT -k -u elastic:$pass https://192.168.131.155:9200/.ds-.fleet-actions-results-2022.03.22-000002/_settings -d '{"logs-*": {"number_of_replicas": "0"}}' -H 'Content-Type: application/json'
{"error":{"root_cause":[{"type":"security_exception","reason":"action [indices:admin/settings/update] is unauthorized for user [elastic] with roles [superuser] on restricted indices [.ds-.fleet-actions-results-2022.03.22-000002], this action is granted by the index privileges [manage,all]"}],"type":"security_exception","reason":"action [indices:admin/settings/update] is unauthorized for user [elastic] with roles [superuser] on restricted indices [.ds-.fleet-actions-results-2022.03.22-000002], this action is granted by the index privileges [manage,all]"},"status":403}

I've created an index template, but now I can't delete that either, since it's in use
In the past I would just modify the pattern and save, then delete but can't do that here

 curl -XGET -k -u elastic:$pass https://localhost:9200/_index_template/.fleet-actions-results?pretty
{
  "index_templates" : [
    {
      "name" : ".fleet-actions-results",
      "index_template" : {
        "index_patterns" : [
          ".fleet-actions-results*"
        ],
        "template" : {
          "settings" : {
            "index" : {
              "number_of_replicas" : "0"
            }
          }
        },
        "composed_of" : [ ],
        "priority" : 90000001,
        "_meta" : {
          "description" : "Test"
        },
        "data_stream" : {
          "hidden" : false,
          "allow_custom_routing" : false
        }
      }
    }
  ]
}