Node Exception with Transport Client


(IronMan2014) #1

I posted earlier with an issue that I spent quite a bit of time trying to
figure out how to setup EC2 cluster, I followed documentation, but still
couldn't get it to work, I have 2 "i.4xlarge instances"

So, I decided to sale down the problem and work with one instance:
I installed the latest 1.0.0 on EC2 instance and "aws plugin 2.0", the
instance works fine from http API but not from my Java/API transport client.

Note, the transport client works fine against my local ES server (0.90.9),
so nothing wrong with the Java client.

//Settings

Settings settings = ImmutableSettings.settingsBuilder()

.put("client.transport.sniff", true)

.put("refresh_interval", "-1") //Needs to be updated after indexing is
done

.put("number_of_shards", 1)

.put("number_of_replicas", "0")

.put("index.merge.policy.merge_factor", 30)

.put("client.transport.ping_timeout", "10s") //Node conn timeout

But when I use My JavaAPI/Transport Client against Version 1.0.0 on the
instance, I get this error:

WARN - Log4jESLogger.internalWarn(124) | [The Stepford Cuckoos] Message not
fully read (response) for [0] handler
future(org.elasticsearch.client.transport.TransportClientNodesService$SimpleNodeSampler$1@2d35da43),
error [true], resettingException in thread "main"
org.elasticsearch.client.transport.NoNodeAvailableException: No node
available

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0ecf9ca-619d-4127-b534-01147d829a79%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

You need to update the client to es 1.0.0

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 21 mars 2014 à 22:22, IronMan2014 sabdalla80@hotmail.com a écrit :

I posted earlier with an issue that I spent quite a bit of time trying to figure out how to setup EC2 cluster, I followed documentation, but still couldn't get it to work, I have 2 "i.4xlarge instances"

So, I decided to sale down the problem and work with one instance:
I installed the latest 1.0.0 on EC2 instance and "aws plugin 2.0", the instance works fine from http API but not from my Java/API transport client.

Note, the transport client works fine against my local ES server (0.90.9), so nothing wrong with the Java client.

//Settings
Settings settings = ImmutableSettings.settingsBuilder()

.put("client.transport.sniff", true)

.put("refresh_interval", "-1") //Needs to be updated after indexing is done

.put("number_of_shards", 1)

.put("number_of_replicas", "0")

.put("index.merge.policy.merge_factor", 30)

.put("client.transport.ping_timeout", "10s") //Node conn timeout

But when I use My JavaAPI/Transport Client against Version 1.0.0 on the instance, I get this error:

WARN - Log4jESLogger.internalWarn(124) | [The Stepford Cuckoos] Message not fully read (response) for [0] handler future(org.elasticsearch.client.transport.TransportClientNodesService$SimpleNodeSampler$1@2d35da43), error [true], resettingException in thread "main" org.elasticsearch.client.transport.NoNodeAvailableException: No node available

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0ecf9ca-619d-4127-b534-01147d829a79%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/AFCE8F63-2647-4D02-B317-C698BCA49692%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(system) #3