Node.max_local_storage_nodes error ruuning elasticsearch


(marwa) #1

i installed elasticsearch5.5.0 ,i did run it and evrything was ok i did't change anything about its configuration but i rerun it and something is wrong ,this error apeared to me ,i don(t know how to fix it

[WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/opt/elasticsearch-5.5.0/data/elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?

i know it's a warn but it stops elasticsearch from running
i changed the node.max_local_storage_nodes in elasticsearch.yml ,i tryed to put it 3 but teh same error reappeared

please any help !!!


(David Pilato) #2

You already have an elasticsearch instance running more likely.


(marwa) #3

thank you , i figured out infact ,i killed the process java then it worked


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.