Node names the same?

Hi All,

I am starting up 3 elasticsearch services to try to utilise the large amount of memory my server has (~390GB).

I have just made copy's of the /etc/init.d script and changed them to point to their own configuration file. Then ran update-rcd to ensure they run on boot..

I can see the 3 processes running all pointing to there own config files.

Each configuration file has the same cluster name

################################### Cluster ###################################

Cluster name identifies your cluster for auto-discovery. If you're running

multiple clusters on the same network, make sure you're using unique names.

cluster.name: elasticsearch

However I've given them different Node names. i.e Node1, Node2 and Node3

#################################### Node #####################################

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific name:

node.name: Node1

However when I when I running 'curl localhost:9200/_nodes/process?pretty' I notice they all have the same Node Name.... is that correct? Also does everything else look ok?

{
"cluster_name" : "elasticsearch",
"nodes" : {
"h74xaIssRkui4_jO-kwsfA" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9302]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9202]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1892,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"8fhp_JSCRZS27gdXNa8KDg" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9301]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9201]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1660,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"_-R2UbIoQNurnZA8_ibLxg" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9300]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1636,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"xPNfdj-rR_SrEbgpxwdWEg" : {
"name" : "logstash-msi-n-logz-1-625-2018",
"transport_address" : "inet[/10.166.132.11:9303]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.1.1",
"build" : "f1585f0",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 625,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

Many thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d7c68cb7-edb2-4708-97dd-5382e0629f40%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Anyone? I'm sorry if this is a silly question, I'm still trying to get my
head around this.

On Wednesday, February 18, 2015 at 7:22:46 PM UTC+11, Marcos Georgopoulos
wrote:

Hi All,

I am starting up 3 elasticsearch services to try to utilise the large
amount of memory my server has (~390GB).

I have just made copy's of the /etc/init.d script and changed them to
point to their own configuration file. Then ran update-rcd to ensure they
run on boot..

I can see the 3 processes running all pointing to there own config files.

Each configuration file has the same cluster name

################################### Cluster
###################################

Cluster name identifies your cluster for auto-discovery. If you're

running

multiple clusters on the same network, make sure you're using unique

names.

cluster.name: elasticsearch

However I've given them different Node names. i.e Node1, Node2 and Node3

#################################### Node
#####################################

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific

name:

node.name: Node1

However when I when I running 'curl localhost:9200/_nodes/process?pretty'
I notice they all have the same Node Name.... is that correct? Also does
everything else look ok?

{
"cluster_name" : "elasticsearch",
"nodes" : {
"h74xaIssRkui4_jO-kwsfA" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9302]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9202]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1892,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"8fhp_JSCRZS27gdXNa8KDg" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9301]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9201]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1660,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"_-R2UbIoQNurnZA8_ibLxg" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9300]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1636,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"xPNfdj-rR_SrEbgpxwdWEg" : {
"name" : "logstash-msi-n-logz-1-625-2018",
"transport_address" : "inet[/10.166.132.11:9303]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.1.1",
"build" : "f1585f0",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 625,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

Many thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/478cc5dd-a9b0-4d3e-9bf8-6cb6367954cb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I'd say there is still something referring to the old config file.
Try running the process and point it to the actual config file -
-Des.config=$path

On 19 February 2015 at 16:27, ElasticSearch Noobie me@marcosg.com wrote:

Anyone? I'm sorry if this is a silly question, I'm still trying to get my
head around this.

On Wednesday, February 18, 2015 at 7:22:46 PM UTC+11, Marcos Georgopoulos
wrote:

Hi All,

I am starting up 3 elasticsearch services to try to utilise the large
amount of memory my server has (~390GB).

I have just made copy's of the /etc/init.d script and changed them to
point to their own configuration file. Then ran update-rcd to ensure they
run on boot..

I can see the 3 processes running all pointing to there own config files.

Each configuration file has the same cluster name

################################### Cluster
###################################

Cluster name identifies your cluster for auto-discovery. If you're

running

multiple clusters on the same network, make sure you're using unique

names.

cluster.name: elasticsearch

However I've given them different Node names. i.e Node1, Node2 and Node3

#################################### Node #####################################

Node names are generated dynamically on startup, so you're relieved

from configuring them manually. You can tie this node to a specific

name:

node.name: Node1

However when I when I running 'curl localhost:9200/_nodes/process?pretty'
I notice they all have the same Node Name.... is that correct? Also does
everything else look ok?

{
"cluster_name" : "elasticsearch",
"nodes" : {
"h74xaIssRkui4_jO-kwsfA" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9302]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9202]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1892,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"8fhp_JSCRZS27gdXNa8KDg" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9301]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9201]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1660,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"_-R2UbIoQNurnZA8_ibLxg" : {
"name" : "Node1",
"transport_address" : "inet[/10.166.132.11:9300]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.4.2",
"build" : "927caff",
"http_address" : "inet[/10.166.132.11:9200]",
"attributes" : {
"master" : "true"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 1636,
"max_file_descriptors" : 65535,
"mlockall" : false
}
},
"xPNfdj-rR_SrEbgpxwdWEg" : {
"name" : "logstash-msi-n-logz-1-625-2018",
"transport_address" : "inet[/10.166.132.11:9303]",
"host" : "msi-n-logz-1",
"ip" : "10.166.132.11",
"version" : "1.1.1",
"build" : "f1585f0",
"attributes" : {
"client" : "true",
"data" : "false"
},
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 625,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}

Many thanks!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/478cc5dd-a9b0-4d3e-9bf8-6cb6367954cb%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/478cc5dd-a9b0-4d3e-9bf8-6cb6367954cb%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9MR4_CG0Eyg6%3DNtfHdh97GMqm3YXnNQDPtoFgL2oYH1g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.