Nodes are not able to connect to the master


(deep saxena) #1

org.elasticsearch.transport.ConnectTransportException: [Crooked
Man][inet[/192.168.202.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:671)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:610)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:580)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:127)
at
org.elasticsearch.cluster.service.InternalClusterService$2.run(InternalClusterService.java:300)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:95)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.net.ConnectException: Connection timed out: no further
information: /192.168.202.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:599)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:312)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

.yaml file contain the default settings, no changes in that, still
not connecting. Is there any issue with the network setting or the
elasticsearch configuration?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c1225b66-2b1e-48e9-941e-23c9fb181328%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jason Wee) #2

Hehehe.. no pun intended... crooked man should not get connected anyway :slight_smile:

scnr

/Jason

On Tue, Dec 24, 2013 at 3:33 PM, deep saxena sandy100ster@gmail.com wrote:

org.elasticsearch.transport.ConnectTransportException: [Crooked Man][inet[/
192.168.202.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:671)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:610)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:580)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:127)
at
org.elasticsearch.cluster.service.InternalClusterService$2.run(InternalClusterService.java:300)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:95)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.net.ConnectException: Connection timed out: no further
information: /192.168.202.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:599)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:312)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

.yaml file contain the default settings, no changes in that, still
not connecting. Is there any issue with the network setting or the
elasticsearch configuration?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c1225b66-2b1e-48e9-941e-23c9fb181328%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHO4itxY1JHrwyCnKYAgEPULMQyym5%2B4BF03rUgsC0Qp6OSsWw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #3

Hey,

connection timed out means, that the other host is not reachable. This can
have dozens of reasons. If the node never joins the cluster, you might have
a firewall problem. If the node already had joined the cluster, your might
have a temporary network outage, or maybe your node is under an extremely
high load. Without proper monitoring and more digging through the log files
this is really hard to tell.

A first try might be, if you are able to reach that port manually on that
host - completely independent from elasticsearch itself. If this does not
work, you got other problems.

--Alex

On Tue, Dec 24, 2013 at 8:33 AM, deep saxena sandy100ster@gmail.com wrote:

org.elasticsearch.transport.ConnectTransportException: [Crooked Man][inet[/
192.168.202.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:671)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:610)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:580)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:127)
at
org.elasticsearch.cluster.service.InternalClusterService$2.run(InternalClusterService.java:300)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:95)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.net.ConnectException: Connection timed out: no further
information: /192.168.202.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:599)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:312)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

.yaml file contain the default settings, no changes in that, still
not connecting. Is there any issue with the network setting or the
elasticsearch configuration?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c1225b66-2b1e-48e9-941e-23c9fb181328%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-EdjRXhqeyao_Fz4zWyd9Wsftbg_kfqu%3DWQE2Z_%3DE%2B5Q%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Amit Soni) #4

Alex - So if I were to look for a right suggestor which works on a part of
index (filtered) and not the entire index, is edge N-gram the best choice?

-Amit.

On Tue, Dec 24, 2013 at 4:21 PM, Alexander Reelsen alr@spinscale.de wrote:

Hey,

connection timed out means, that the other host is not reachable. This can
have dozens of reasons. If the node never joins the cluster, you might have
a firewall problem. If the node already had joined the cluster, your might
have a temporary network outage, or maybe your node is under an extremely
high load. Without proper monitoring and more digging through the log files
this is really hard to tell.

A first try might be, if you are able to reach that port manually on that
host - completely independent from elasticsearch itself. If this does not
work, you got other problems.

--Alex

On Tue, Dec 24, 2013 at 8:33 AM, deep saxena sandy100ster@gmail.comwrote:

org.elasticsearch.transport.ConnectTransportException: [Crooked
Man][inet[/192.168.202.1:9300]] connect_timeout[30s]
at
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:671)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:610)
at
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:580)
at
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:127)
at
org.elasticsearch.cluster.service.InternalClusterService$2.run(InternalClusterService.java:300)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:95)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:662)
Caused by: java.net.ConnectException: Connection timed out: no further
information: /192.168.202.1:9300
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:599)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)
at
org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:312)
at
org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)
at
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)

.yaml file contain the default settings, no changes in that, still
not connecting. Is there any issue with the network setting or the
elasticsearch configuration?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c1225b66-2b1e-48e9-941e-23c9fb181328%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGCwEM-EdjRXhqeyao_Fz4zWyd9Wsftbg_kfqu%3DWQE2Z_%3DE%2B5Q%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAOGaQKpJHhyQ2z%3DePZbLe%2BCVhUe-HZ39Wt-7UZJnkg7RZG3ww%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5