Nodes aren't joining cluster with ec2 discovery

Ubuntu 12.04.2 with ES 0.20.6

elasticsearch.yml:

cluster.name: my-search
cloud:
aws:
access_key: mine
secret_key: mine

dicovery:
type: ec2
ec2:
tag:
role: elasticsearch
host_type: private_ip
availability_zones: us-west-2a, us-west-2b, us-west-2c

on any node I can run: curl -XGET
'http://localhost:9200/_cluster/health?pretty=true'

and get
{
"cluster_name" : "my-search",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 0,
"active_shards" : 0,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

No nodes every join the cluster. AWS credentials are EC2-Read-only
(EC2::Describe).

I followed this
guide: http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/

And here is one of the logs:

[2013-07-24 18:07:40,078][WARN ][common.jna ] Unknown
mlockall error 0
[2013-07-24 18:07:40,088][INFO ][node ] [Vanguard]
{0.20.6}[13994]: initializing ...
[2013-07-24 18:07:40,107][INFO ][plugins ] [Vanguard]
loaded [cloud-aws], sites []
[2013-07-24 18:07:42,029][DEBUG][discovery.zen.ping.multicast] [Vanguard]
using group [224.2.2.4], with port [54328], ttl [3], and address [null]
[2013-07-24 18:07:42,034][DEBUG][discovery.zen.ping.unicast] [Vanguard]
using initial hosts [], with concurrent_connects [10]
[2013-07-24 18:07:42,036][DEBUG][discovery.zen ] [Vanguard]
using ping.timeout [3s], master_election.filter_client [true],
master_election.filter_data [false]
[2013-07-24 18:07:42,037][DEBUG][discovery.zen.elect ] [Vanguard]
using minimum_master_nodes [-1]
[2013-07-24 18:07:42,039][DEBUG][discovery.zen.fd ] [Vanguard]
[master] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2013-07-24 18:07:42,045][DEBUG][discovery.zen.fd ] [Vanguard]
[node ] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2013-07-24 18:07:43,192][INFO ][node ] [Vanguard]
{0.20.6}[13994]: initialized
[2013-07-24 18:07:43,193][INFO ][node ] [Vanguard]
{0.20.6}[13994]: starting ...
[2013-07-24 18:07:43,319][INFO ][transport ] [Vanguard]
bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address
{inet[/10.22.132.213:9300]}
[2013-07-24 18:07:46,341][DEBUG][discovery.zen ] [Vanguard]
filtered ping responses: (filter_client[true], filter_data[false]) {none}
[2013-07-24 18:07:46,345][INFO ][cluster.service ] [Vanguard]
new_master [Vanguard][2XcG9aHOSsSgsc-tiF6pkA][inet[/10.22.132.213:9300]],
reason: zen-disco-join (elected_as_master)
[2013-07-24 18:07:46,378][INFO ][discovery ] [Vanguard]
my-search/2XcG9aHOSsSgsc-tiF6pkA
[2013-07-24 18:07:46,444][INFO ][http ] [Vanguard]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address
{inet[/10.22.132.213:9200]}
[2013-07-24 18:07:46,444][INFO ][node ] [Vanguard]
{0.20.6}[13994]: started
[2013-07-24 18:07:46,497][INFO ][gateway ] [Vanguard]
recovered [0] indices into cluster_state

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

It looks like you are still using multicast, which won't work at all in AWS.
Plugin does work BTW, make sure you are allowing TCP/9300 from the sec
group your instances live (i.e., from the secgroup to itself).
On 25/07/2013 4:12 AM, "Barry Morrison" barry@versal.com wrote:

Ubuntu 12.04.2 with ES 0.20.6

elasticsearch.yml:

cluster.name: my-search
cloud:
aws:
access_key: mine
secret_key: mine

dicovery:
type: ec2
ec2:
tag:
role: elasticsearch
host_type: private_ip
availability_zones: us-west-2a, us-west-2b, us-west-2c

on any node I can run: curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'

and get
{
"cluster_name" : "my-search",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 0,
"active_shards" : 0,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

No nodes every join the cluster. AWS credentials are EC2-Read-only
(EC2::Describe).

I followed this guide:
http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/

And here is one of the logs:

[2013-07-24 18:07:40,078][WARN ][common.jna ] Unknown
mlockall error 0
[2013-07-24 18:07:40,088][INFO ][node ] [Vanguard]
{0.20.6}[13994]: initializing ...
[2013-07-24 18:07:40,107][INFO ][plugins ] [Vanguard]
loaded [cloud-aws], sites []
[2013-07-24 18:07:42,029][DEBUG][discovery.zen.ping.multicast] [Vanguard]
using group [224.2.2.4], with port [54328], ttl [3], and address [null]
[2013-07-24 18:07:42,034][DEBUG][discovery.zen.ping.unicast] [Vanguard]
using initial hosts [], with concurrent_connects [10]
[2013-07-24 18:07:42,036][DEBUG][discovery.zen ] [Vanguard]
using ping.timeout [3s], master_election.filter_client [true],
master_election.filter_data [false]
[2013-07-24 18:07:42,037][DEBUG][discovery.zen.elect ] [Vanguard]
using minimum_master_nodes [-1]
[2013-07-24 18:07:42,039][DEBUG][discovery.zen.fd ] [Vanguard]
[master] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2013-07-24 18:07:42,045][DEBUG][discovery.zen.fd ] [Vanguard]
[node ] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2013-07-24 18:07:43,192][INFO ][node ] [Vanguard]
{0.20.6}[13994]: initialized
[2013-07-24 18:07:43,193][INFO ][node ] [Vanguard]
{0.20.6}[13994]: starting ...
[2013-07-24 18:07:43,319][INFO ][transport ] [Vanguard]
bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/
10.22.132.213:9300]}
[2013-07-24 18:07:46,341][DEBUG][discovery.zen ] [Vanguard]
filtered ping responses: (filter_client[true], filter_data[false]) {none}
[2013-07-24 18:07:46,345][INFO ][cluster.service ] [Vanguard]
new_master [Vanguard][2XcG9aHOSsSgsc-tiF6pkA][inet[/10.22.132.213:9300]],
reason: zen-disco-join (elected_as_master)
[2013-07-24 18:07:46,378][INFO ][discovery ] [Vanguard]
my-search/2XcG9aHOSsSgsc-tiF6pkA
[2013-07-24 18:07:46,444][INFO ][http ] [Vanguard]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
10.22.132.213:9200]}
[2013-07-24 18:07:46,444][INFO ][node ] [Vanguard]
{0.20.6}[13994]: started
[2013-07-24 18:07:46,497][INFO ][gateway ] [Vanguard]
recovered [0] indices into cluster_state

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

BTW if u can, upgrade your version of elastic search.
On 25/07/2013 4:12 AM, "Barry Morrison" barry@versal.com wrote:

Ubuntu 12.04.2 with ES 0.20.6

elasticsearch.yml:

cluster.name: my-search
cloud:
aws:
access_key: mine
secret_key: mine

dicovery:
type: ec2
ec2:
tag:
role: elasticsearch
host_type: private_ip
availability_zones: us-west-2a, us-west-2b, us-west-2c

on any node I can run: curl -XGET '
http://localhost:9200/_cluster/health?pretty=true'

and get
{
"cluster_name" : "my-search",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 0,
"active_shards" : 0,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

No nodes every join the cluster. AWS credentials are EC2-Read-only
(EC2::Describe).

I followed this guide:
http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/

And here is one of the logs:

[2013-07-24 18:07:40,078][WARN ][common.jna ] Unknown
mlockall error 0
[2013-07-24 18:07:40,088][INFO ][node ] [Vanguard]
{0.20.6}[13994]: initializing ...
[2013-07-24 18:07:40,107][INFO ][plugins ] [Vanguard]
loaded [cloud-aws], sites []
[2013-07-24 18:07:42,029][DEBUG][discovery.zen.ping.multicast] [Vanguard]
using group [224.2.2.4], with port [54328], ttl [3], and address [null]
[2013-07-24 18:07:42,034][DEBUG][discovery.zen.ping.unicast] [Vanguard]
using initial hosts [], with concurrent_connects [10]
[2013-07-24 18:07:42,036][DEBUG][discovery.zen ] [Vanguard]
using ping.timeout [3s], master_election.filter_client [true],
master_election.filter_data [false]
[2013-07-24 18:07:42,037][DEBUG][discovery.zen.elect ] [Vanguard]
using minimum_master_nodes [-1]
[2013-07-24 18:07:42,039][DEBUG][discovery.zen.fd ] [Vanguard]
[master] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2013-07-24 18:07:42,045][DEBUG][discovery.zen.fd ] [Vanguard]
[node ] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2013-07-24 18:07:43,192][INFO ][node ] [Vanguard]
{0.20.6}[13994]: initialized
[2013-07-24 18:07:43,193][INFO ][node ] [Vanguard]
{0.20.6}[13994]: starting ...
[2013-07-24 18:07:43,319][INFO ][transport ] [Vanguard]
bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/
10.22.132.213:9300]}
[2013-07-24 18:07:46,341][DEBUG][discovery.zen ] [Vanguard]
filtered ping responses: (filter_client[true], filter_data[false]) {none}
[2013-07-24 18:07:46,345][INFO ][cluster.service ] [Vanguard]
new_master [Vanguard][2XcG9aHOSsSgsc-tiF6pkA][inet[/10.22.132.213:9300]],
reason: zen-disco-join (elected_as_master)
[2013-07-24 18:07:46,378][INFO ][discovery ] [Vanguard]
my-search/2XcG9aHOSsSgsc-tiF6pkA
[2013-07-24 18:07:46,444][INFO ][http ] [Vanguard]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
10.22.132.213:9200]}
[2013-07-24 18:07:46,444][INFO ][node ] [Vanguard]
{0.20.6}[13994]: started
[2013-07-24 18:07:46,497][INFO ][gateway ] [Vanguard]
recovered [0] indices into cluster_state

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.