NoNodeAvailableException while accessing remote elastic server using 9300 port

Hi,

I am using elastic search server to search full text. Here i am able to
perform text search from my local using default elasticsearch.yml
configurations and no cluster names and no nodes defined here using below
code.

client = new TransportClient().addTransportAddress(new
InetSocketTransportAddress("127.0.0.1", 9300));

I have hosted elastic server on other machine in same network and trying to
access it using that machine IP

client = new TransportClient().addTransportAddress(new
InetSocketTransportAddress("remoteHost", 9300));

I am not able to connect, i am getting following error.

org.elasticsearch.client.transport.NoNodeAvailableException: None of the
configured nodes are available: []
at
org.elasticsearch.client.transport.TransportClientNodesService.ensureNodesAreAvailable(TransportClientNodesService.java:278)
at
org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:197)
at
org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:106)
at
org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:97)

Please help me, i am not sure where i am doing wrong.

Thanks,
Vijaya

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dbbffe70-7591-41b2-939b-a3b46a816fee%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

try localhost instead of 127.0.0.1. if it works, I doubt on configuration.

 On Wednesday, March 25, 2015 4:22 AM, Vijayakumari B N [via ElasticSearch Users] <ml-node+s115913n4072558h26@n3.nabble.com> wrote:

Hi,
I am using elastic search server to search full text. Here i am able to perform text search from my local using default elasticsearch.yml configurations and no cluster names and no nodes defined here using below code.
client = new TransportClient().addTransportAddress(new InetSocketTransportAddress("127.0.0.1", 9300));

I have hosted elastic server on other machine in same network and trying to access it using that machine IP
client = new TransportClient().addTransportAddress(new InetSocketTransportAddress("remoteHost", 9300));

I am not able to connect, i am getting following error.
org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [] at org.elasticsearch.client.transport.TransportClientNodesService.ensureNodesAreAvailable(TransportClientNodesService.java:278) at org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:197) at org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:106) at org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:97)
Please help me, i am not sure where i am doing wrong.
Thanks,Vijaya

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dbbffe70-7591-41b2-939b-a3b46a816fee%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

If you reply to this email, your message will be added to the discussion below: http://elasticsearch-users.115913.n3.nabble.com/NoNodeAvailableException-while-accessing-remote-elastic-server-using-9300-port-tp4072558.html To start a new topic under ElasticSearch Users, email ml-node+s115913n115913h31@n3.nabble.com
To unsubscribe from ElasticSearch Users, click here.
NAML

Hi Vijya,

To connect to cluster one node also we have to define clustername .jsut
define cluster name .The following code worked for me

               Settings settings 

=ImmutableSettings.settingsBuilder().put("cluster.name",clustername).build();
TransportClient transportClient = new TransportClient(settings);
transportClient = transportClient.addTransportAddress(new
InetSocketTransportAddress("hostname",9300));
hope it helps!!!!!

On Wednesday, March 25, 2015 at 2:52:03 PM UTC+5:30, Vijayakumari B N wrote:

Hi,

I am using elastic search server to search full text. Here i am able to
perform text search from my local using default elasticsearch.yml
configurations and no cluster names and no nodes defined here using below
code.

client = new TransportClient().addTransportAddress(new
InetSocketTransportAddress("127.0.0.1", 9300));

I have hosted elastic server on other machine in same network and trying
to access it using that machine IP

client = new TransportClient().addTransportAddress(new
InetSocketTransportAddress("remoteHost", 9300));

I am not able to connect, i am getting following error.

org.elasticsearch.client.transport.NoNodeAvailableException: None of the
configured nodes are available: []
at
org.elasticsearch.client.transport.TransportClientNodesService.ensureNodesAreAvailable(TransportClientNodesService.java:278)
at
org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:197)
at
org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:106)
at
org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:97)

Please help me, i am not sure where i am doing wrong.

Thanks,
Vijaya

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/59aa470d-46fa-4594-a34c-303dd8ce2c2b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.