Not able to access Kibana


(Asif Bhat) #1

Hi Team,

I have installed ELK stack on the Cent OS system.

Now I am trying to login to Kibana but I am seeing below page -
image

Used below URL -
http://HOSTNAME:5601/

Also used elastic stack domain that I used in the Nginx configuration.

Just an FYI - Kibana , ElasticSearch and Logstash is showing up using below command

systemctl status kibana
systemctl status elasticsearch
systemctl status logstash

Any ideas what I am missing ?

Kind Regards,
Asif Bhat


Error in Kibana after X-PACK installation
(Tim Roes) #2

Hi,

if you setup a reverse proxy for Kibana, shouldn't you rather try to access http://hostname instead of http://hostname:5601? If you are trying to access Kibana via hostname:5601 have you made sure it's really be accessible from the outside network, and not just within your server?

Cheers,
Tim


(Asif Bhat) #3

I tried both -

http://hostname
http://hostname:5601

What setting I need to perform to make it accessible from outside network ?


(Tim Roes) #4

I can't provide any details about your network configuration. Does Kibana respond, if you try to access it from the server host itself via localhost:5601?


(Asif Bhat) #5

Moreover when I am using only hostname I am getting below screen -

Entered kibanaadmin and the password but it is still showing the same window.


(Asif Bhat) #6

Any general setting from the ELK stack ?


(Tim Roes) #7

That login is coming from your reverse proxy (and not from Kibana). It's coming from the line:

auth_basic_user_file /etc/nginx/.kibana-user

So you should provide the credentials, that are written within that file on the server?

Cheers,
Tim


(Asif Bhat) #8

My Bad.

I was using the kibanaadmin instead of "admin".

Thanks a ton for your help.


(Tim Roes) #9

Glad we could solve that issue so easily :slight_smile:

Wish you a nice day,
Tim


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.