Not able to add data node to a elasticsearch cluster


#1

Dear all,

I'm currently trying to make the following elasticsearch cluster:

My 3 master nodes are working fine, but my 3 others data nodes are not able to be connected to the masters:
error:

[2018-10-23T14:59:41,287][WARN ][o.e.d.z.ZenDiscovery ] [Data_Node_1] not enough master nodes discovered during pinging (found [[]], but needed [3]), pinging again

I trying to find a solution to have two node per vm, do you know how to do that?

Many tkanks for your help

below my actuals elasticsearch.yml configuration:

Master 1:

cluster.name: Ken_O_Bee
node.name: Master_1
node.master: true
node.data: true
path.data: /opt/node_data/master1
path.logs: /var/log/elasticsearch/master1
bootstrap.memory_lock: true

network.host: 172.20.10.7
network.bind_host: 0.0.0.0
http.port: 9200

discovery.zen.ping.unicast.hosts: ["172.20.10.7" , "172.20.10.6" , "172.20.10.5"]
discovery.zen.minimum_master_nodes: 2

xpack.security.enabled: false
xpack.monitoring.enabled: true
xpack.ml.enabled: false
xpack.graph.enabled: false
xpack.watcher.enabled: false
xpack.monitoring.collection.enabled: true

Master 2:

cluster.name: Ken_O_Bee
node.name: Master_2
node.master: true
node.data: true
path.data: /opt/node_data/master2
path.logs: /var/log/elasticsearch/master2
bootstrap.memory_lock: true

network.host: 172.20.10.6
network.bind_host: 0.0.0.0
http.port: 9200

discovery.zen.ping.unicast.hosts: ["172.20.10.7" , "172.20.10.6" , "172.20.10.5"]
discovery.zen.minimum_master_nodes: 2

xpack.security.enabled: false
xpack.monitoring.enabled: true
xpack.ml.enabled: false
xpack.graph.enabled: false
xpack.watcher.enabled: false
xpack.monitoring.collection.enabled: true

Master 3:

cluster.name: Ken_O_Bee
node.name: Master_3
node.master: true
node.data: true
path.data: /opt/node_data/master3
path.logs: /var/log/elasticsearch/master3
bootstrap.memory_lock: true

network.host: 172.20.10.5
network.bind_host: 0.0.0.0
http.port: 9200

discovery.zen.ping.unicast.hosts: ["172.20.10.7" , "172.20.10.6" , "172.20.10.5"]
discovery.zen.minimum_master_nodes: 2

xpack.security.enabled: false
xpack.monitoring.enabled: true
xpack.ml.enabled: false
xpack.graph.enabled: false
xpack.watcher.enabled: false
xpack.monitoring.collection.enabled: true

Data_node example:

cluster.name: Ken_O_Bee
node.name: Data_Node_1
node.master: false
node.data: true
path.data: /opt/node_data/data_1
path.logs: /var/log/elasticsearch/data_node_1

bootstrap.memory_lock: true

network.bind_host: 0.0.0.0
http.port: 9201
transport.tcp.port: 9301

discovery.zen.ping.unicast.hosts: ["172.20.10.7" , "172.20.10.6" , "172.20.10.5"]
discovery.zen.minimum_master_nodes: 3

xpack.security.enabled: false
xpack.monitoring.enabled: true
xpack.ml.enabled: false
xpack.graph.enabled: false
xpack.watcher.enabled: false
xpack.monitoring.collection.enabled: true

(Xavier Facq) #2

Hi,

In your data nodes configuration you need to add the port of unicast master hosts :

discovery.zen.ping.unicast.hosts: ["172.20.10.7:9300" , "172.20.10.6:9300" , "172.20.10.5:9300"]

bye,
Xavier


#3

Hi Xavier,

You're right!! is working, thank you for your quite response:


(Xavier Facq) #4

:+1: good to hear that !
You can mark as resolved !

enjoy,
Xavier


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.