Not able to configure Index pattern on date field


(Vikas Gopal) #1

Hi Experts ,

In ES 2.1 I have created following index . It has 2 date fields , Publish_date and test_date but in kibana when I am configuring an Index pattern I can only see publish_date in the time filed drop down .So my question is

  1. why only publish_date why not test_date also be there

  2. After selecting publish_date why Kibana throwing an error in discover page "Discover: An error occurred with your request. Reset your inputs and try again."

    PUT /library/books/1
    {
    "title": "A fly on the wall part2",
    "name" : {
    "first" : "vikas",
    "last" : "gopal"
    },
    "publish_date" : "2015-12-08T12:40:33.661",
    "test_date" : "1449716657959",
    "price" : 510
    }

This is what I can see in the setting of this index


(Mark Walkom) #2

It's cause the test_date has been created as a string, you should set explicit mappings to make sure it will be a datetime, and then reindex.


(Vikas Gopal) #3

So I set explicit mapping and again reindex. I can see both the date fileds in the selection but Discover tab is still throwing an error "Discover: An error occurred with your request. Reset your inputs and try again."

PUT library
{
  "mappings": {
  "my_type": {
 "properties": {
"date": {
  "type":   "date",
  "format": "yyy-MM-dd HH:mm:ss||yyyy-MM-dd||epoch_millis"
 }
}
}
  }
}

(Mark Walkom) #4

Check your KB and ES logs?


(system) #5