Not able to do _bulk request. Throwing ActionRequestValidationException Error


(smruti) #1

Hi,

The bulk operation is throwing error. Could someone please have a
look. I read some earlier posts but did not get any clue. i am running
0.12 elastic search version.

Error :
response status: 500
{u'error': u'ActionRequestValidationException[Validation Failed:
1: no requests added]'}

Request :

making POST request to path: localhost 9200 /_bulk with body: "{"index
": {"_type": "india", "_index": "location"}}\n{"timezone":
"Asia/Kolkata", "location": {"lat": "27.75", "lon":
"88.26667"}, "id": "1252676", "name": "Zemu Glacier"}\n"

Thanks
Smruti


(Shay Banon) #2

The format is bulk API has changed in 0.12, it requires setting _index,
_type and _id (and not index, type, and id).

-shay.banon

On Sun, Oct 31, 2010 at 6:39 AM, Smruti smruti.parida@gmail.com wrote:

Hi,

The bulk operation is throwing error. Could someone please have a
look. I read some earlier posts but did not get any clue. i am running
0.12 elastic search version.

Error :
response status: 500
{u'error': u'ActionRequestValidationException[Validation Failed:
1: no requests added]'}

Request :

making POST request to path: localhost 9200 /_bulk with body: "{"index
": {"_type": "india", "_index": "location"}}\n{"timezone":
"Asia/Kolkata", "location": {"lat": "27.75", "lon":
"88.26667"}, "id": "1252676", "name": "Zemu Glacier"}\n"

Thanks
Smruti


(smruti) #3

Thanks Shay..

But if you observe, i am using the same format as mentiones above.

{"index": {"_type": "india", "_index": "location"}}\n
....

Is not it correct ?

~Smruti

On Oct 31, 1:52 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

The format is bulk API has changed in 0.12, it requires setting _index,
_type and _id (and not index, type, and id).

-shay.banon

On Sun, Oct 31, 2010 at 6:39 AM, Smruti smruti.par...@gmail.com wrote:

Hi,

The bulk operation is throwing error. Could someone please have a
look. I read some earlier posts but did not get any clue. i am running
0.12 elastic search version.

Error :
response status: 500
{u'error': u'ActionRequestValidationException[Validation Failed:
1: no requests added]'}

Request :

making POST request to path: localhost 9200 /_bulk with body: "{"index
": {"_type": "india", "_index": "location"}}\n{"timezone":
"Asia/Kolkata", "location": {"lat": "27.75", "lon":
"88.26667"}, "id": "1252676", "name": "Zemu Glacier"}\n"

Thanks
Smruti


(Shay Banon) #4

Sorry, I missed that. Does it work via curl? What library do you use to
interact with elasticsearch?

On Sun, Oct 31, 2010 at 7:51 PM, Smruti smruti.parida@gmail.com wrote:

Thanks Shay..

But if you observe, i am using the same format as mentiones above.

{"index": {"_type": "india", "_index": "location"}}\n
....

Is not it correct ?

~Smruti

On Oct 31, 1:52 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

The format is bulk API has changed in 0.12, it requires setting _index,
_type and _id (and not index, type, and id).

-shay.banon

On Sun, Oct 31, 2010 at 6:39 AM, Smruti smruti.par...@gmail.com wrote:

Hi,

The bulk operation is throwing error. Could someone please have a
look. I read some earlier posts but did not get any clue. i am running
0.12 elastic search version.

Error :
response status: 500
{u'error': u'ActionRequestValidationException[Validation Failed:
1: no requests added]'}

Request :

making POST request to path: localhost 9200 /_bulk with body: "{"index
": {"_type": "india", "_index": "location"}}\n{"timezone":
"Asia/Kolkata", "location": {"lat": "27.75", "lon":
"88.26667"}, "id": "1252676", "name": "Zemu Glacier"}\n"

Thanks
Smruti


(smruti) #5

it does not work via curl as well. I am using pyes present at


I checked the pyes connector code, and I think it is fine according to
the bulk upload protocol.

On Oct 31, 10:54 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Sorry, I missed that. Does it work via curl? What library do you use to
interact with elasticsearch?

On Sun, Oct 31, 2010 at 7:51 PM, Smruti smruti.par...@gmail.com wrote:

Thanks Shay..

But if you observe, i am using the same format as mentiones above.

{"index": {"_type": "india", "_index": "location"}}\n
....

Is not it correct ?

~Smruti

On Oct 31, 1:52 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

The format is bulk API has changed in 0.12, it requires setting _index,
_type and _id (and not index, type, and id).

-shay.banon

On Sun, Oct 31, 2010 at 6:39 AM, Smruti smruti.par...@gmail.com wrote:

Hi,

The bulk operation is throwing error. Could someone please have a
look. I read some earlier posts but did not get any clue. i am running
0.12 elastic search version.

Error :
response status: 500
{u'error': u'ActionRequestValidationException[Validation Failed:
1: no requests added]'}

Request :

making POST request to path: localhost 9200 /_bulk with body: "{"index
": {"_type": "india", "_index": "location"}}\n{"timezone":
"Asia/Kolkata", "location": {"lat": "27.75", "lon":
"88.26667"}, "id": "1252676", "name": "Zemu Glacier"}\n"

Thanks
Smruti


(Lukáš Vlček) #6

Hi,

did you check the following thread in mail list?
http://elasticsearch-users.115913.n3.nabble.com/Bulk-via-curl-not-working-in-data-in-file-tp1793039p1793039.html

I had problems using bulk api via curl and I was getting the same exception.
Obviously the problem was the "new line" character.
Note that when I used curl I did not explicitly included "\n" into data.

Regards,
Lukas

On Mon, Nov 1, 2010 at 5:42 AM, Smruti smruti.parida@gmail.com wrote:

it does not work via curl as well. I am using pyes present at
http://github.com/aparo/pyes
I checked the pyes connector code, and I think it is fine according to
the bulk upload protocol.

On Oct 31, 10:54 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Sorry, I missed that. Does it work via curl? What library do you use to
interact with elasticsearch?

On Sun, Oct 31, 2010 at 7:51 PM, Smruti smruti.par...@gmail.com wrote:

Thanks Shay..

But if you observe, i am using the same format as mentiones above.

{"index": {"_type": "india", "_index": "location"}}\n
....

Is not it correct ?

~Smruti

On Oct 31, 1:52 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

The format is bulk API has changed in 0.12, it requires setting
_index,

_type and _id (and not index, type, and id).

-shay.banon

On Sun, Oct 31, 2010 at 6:39 AM, Smruti smruti.par...@gmail.com
wrote:

Hi,

The bulk operation is throwing error. Could someone please have a
look. I read some earlier posts but did not get any clue. i am
running

0.12 elastic search version.

Error :
response status: 500
{u'error': u'ActionRequestValidationException[Validation Failed:
1: no requests added]'}

Request :

making POST request to path: localhost 9200 /_bulk with body:
"{"index

": {"_type": "india", "_index":
"location"}}\n{"timezone":

"Asia/Kolkata", "location": {"lat": "27.75", "lon":
"88.26667"}, "id": "1252676", "name": "Zemu Glacier"}\n"

Thanks
Smruti


(system) #7