Not getting reroute API to work

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine at a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]];
nested: ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]],
to [Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its
not allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Are you using ElasticSearch 0.20.x?

ElasticSearch 0.90.x is better at balancing shards across nodes.
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:01 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine at a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]]; nested:
ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]], to
[Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its not
allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I am using .20.x
I dont plan to go back on .19.x
Can i know why the reroute API told so.

Thanks
Vineeth

On Fri, Mar 22, 2013 at 2:57 PM, Jaap Taal jaap@q42.nl wrote:

Are you using ElasticSearch 0.20.x?

ElasticSearch 0.90.x is better at balancing shards across nodes.
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:01 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine at
a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a
node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt
get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]]; nested:
ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]], to
[Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its
not
allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Can you try:
curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "owihkXRiQsao94suzna1WQ", "from_node" : "WKM8HDp-Rt23nc9LUVn1SQ"
}
}
]
}'

Just wondering if log message is correct...

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 mars 2013 à 10:55, Vineeth Mohan vineethmohan@algotree.com a écrit :

I am using .20.x
I dont plan to go back on .19.x
Can i know why the reroute API told so.

Thanks
Vineeth

On Fri, Mar 22, 2013 at 2:57 PM, Jaap Taal jaap@q42.nl wrote:
Are you using ElasticSearch 0.20.x?

ElasticSearch 0.90.x is better at balancing shards across nodes.
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:01 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine at a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]]; nested:
ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]], to
[Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its not
allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Vineeth,

If you have 4 nodes and 4 shards and you want each node to run 1 shard, you
should simply turn off replicas and
set index.routing.allocation.total_shards_per_node to 1 like this:

curl -XPUT localhost:9200/algotree/_settings -d
'{"index.routing.allocation.total_shards_per_node": 1,
"index.number_of_replicas": 0}'

No need to mess with reroute API.

If you want to have 1 replica with 4 shards and 4 nodes you need to allow 2
shards to run per node like this:

curl -XPUT localhost:9200/algotree/_settings -d
'{"index.routing.allocation.total_shards_per_node": 2,
"index.number_of_replicas": 1}'

By the way, I think in your example of reroute API request to_node and
from_node are switched.

Igor

On Friday, March 22, 2013 5:55:43 AM UTC-4, Vineeth Mohan wrote:

I am using .20.x
I dont plan to go back on .19.x
Can i know why the reroute API told so.

Thanks
Vineeth

On Fri, Mar 22, 2013 at 2:57 PM, Jaap Taal <ja...@q42.nl <javascript:>>wrote:

Are you using ElasticSearch 0.20.x?

ElasticSearch 0.90.x is better at balancing shards across nodes.
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:01 AM, Vineeth Mohan
<vineet...@algotree.com <javascript:>> wrote:

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine
at a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a
node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt
get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]]; nested:
ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]], to
[Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its
not
allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google
Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

0.90.x is an upgrade from 0.20.x, RC1 just came out the last couple of days.
http://www.elasticsearch.org/blog/2013/03/20/0.90.0.RC1-released.html
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:55 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

I am using .20.x
I dont plan to go back on .19.x
Can i know why the reroute API told so.

Thanks
Vineeth

On Fri, Mar 22, 2013 at 2:57 PM, Jaap Taal jaap@q42.nl wrote:

Are you using ElasticSearch 0.20.x?

ElasticSearch 0.90.x is better at balancing shards across nodes.
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:01 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine at
a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a
node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt
get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]]; nested:
ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]], to
[Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its
not
allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google
Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Also see https://github.com/elasticsearch/elasticsearch/issues/2555
and http://www.elasticsearch.org/blog/2013/02/26/0.90.0.Beta1-released.html
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:55 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

I am using .20.x
I dont plan to go back on .19.x
Can i know why the reroute API told so.

Thanks
Vineeth

On Fri, Mar 22, 2013 at 2:57 PM, Jaap Taal jaap@q42.nl wrote:

Are you using ElasticSearch 0.20.x?

ElasticSearch 0.90.x is better at balancing shards across nodes.
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:01 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine at
a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a
node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt
get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]]; nested:
ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]], to
[Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its
not
allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google
Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Sorry about copying the wrong command.
I actually tried both the combination of from and to and unfortunately i
swaped their output up while pasting in the group.

@igor - Yes i finally did that. Made it 0 replica and hence it got balances
all over.

Let me try your other suggestions.

Thanks
Vineeth

On Fri, Mar 22, 2013 at 6:49 PM, David Pilato david@pilato.fr wrote:

Can you try:
curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "owihkXRiQsao94suzna1WQ", "from_node" :
"WKM8HDp-Rt23nc9LUVn1SQ"
}
}
]
}'

Just wondering if log message is correct...

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 22 mars 2013 à 10:55, Vineeth Mohan vineethmohan@algotree.com a
écrit :

I am using .20.x
I dont plan to go back on .19.x
Can i know why the reroute API told so.

Thanks
Vineeth

On Fri, Mar 22, 2013 at 2:57 PM, Jaap Taal jaap@q42.nl wrote:

Are you using ElasticSearch 0.20.x?

ElasticSearch 0.90.x is better at balancing shards across nodes.
Jaap Taal

[ Q42 BV | tel 070 44523 42 | direct 070 44523 65 | http://q42.nl |
Waldorpstraat 17F, Den Haag | Vijzelstraat 72 unit 4.23, Amsterdam |
KvK 30164662 ]

On Fri, Mar 22, 2013 at 10:01 AM, Vineeth Mohan
vineethmohan@algotree.com wrote:

Hi ,

We have 4 machines and 4 shard. We want one shard to run in a machine
at a
time.
But then head is telling me that Shard 1 and Shard 3 are present in a
node
and another node is sitting idle with just a replica of shard 1.

So i was trying to rebalance this using the reroute API. But i couldnt
get
it to work.
Kindly see what i went wrong.
Also please find the head UI snapshot attached.

curl -XPOST 'localhost:9200/_cluster/reroute' -d '{
"commands" : [ {
"move" :
{
"index" : "algotree", "shard" : 3,
"to_node" : "WKM8HDp-Rt23nc9LUVn1SQ", "from_node" :
"owihkXRiQsao94suzna1WQ"
}
}
]
}'
{"error":"
RemoteTransportException[[Bedlam
II][inet[/192.168.1.246:9300]][cluster/reroute]]; nested:
ElasticSearchIllegalArgumentException[[move_allocation] can't move
[algotree][3], from
[Jubilee][WKM8HDp-Rt23nc9LUVn1SQ][inet[/192.168.1.243:9300]], to
[Mantis][owihkXRiQsao94suzna1WQ][inet[/192.168.1.247:9300]], since its
not
allowed, reason: [YES()][YES()][YES()][YES()][YES()][YES()][NO()]];
","status":400}

Thanks
Vineeth

--
You received this message because you are subscribed to the Google
Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.