Not returning source in the response


(Amit Soni) #1

Hi everyone - This is something which might have been asked already and
hence apology in advance (since I still couldnt find it on the web)

Can you pl let me know how I can request "source" not to be included in the
response? I do want to store the source but is there a way I can specify
that source should not be part of my query response?

-Amit.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAOGaQ%2BdmK2rDBV4Pvv2FTD3dbaLFwxH1ac%3D9cwGfmwnH7Ri2Q%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #2

From my experience, if you set the fields param (even if it set to an empty
list), the source will not be returned. Makes sense since basically the
source is just the _source field.

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-fields.html

--
Ivan

On Thu, Dec 19, 2013 at 8:48 AM, Amit Soni amitsoni29@gmail.com wrote:

Hi everyone - This is something which might have been asked already and
hence apology in advance (since I still couldnt find it on the web)

Can you pl let me know how I can request "source" not to be included in
the response? I do want to store the source but is there a way I can
specify that source should not be part of my query response?

-Amit.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAAOGaQ%2BdmK2rDBV4Pvv2FTD3dbaLFwxH1ac%3D9cwGfmwnH7Ri2Q%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCX6g%3DogP2Uqnn%2BQ4nnT1gpyUq_MGCL77U-h0gbaEz5Pg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Amit Soni) #3

Thanks much Ivan! I will give this a try.

-Amit.

On Thu, Dec 19, 2013 at 9:06 AM, Ivan Brusic ivan@brusic.com wrote:

From my experience, if you set the fields param (even if it set to an
empty list), the source will not be returned. Makes sense since basically
the source is just the _source field.

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-request-fields.html

--
Ivan

On Thu, Dec 19, 2013 at 8:48 AM, Amit Soni amitsoni29@gmail.com wrote:

Hi everyone - This is something which might have been asked already and
hence apology in advance (since I still couldnt find it on the web)

Can you pl let me know how I can request "source" not to be included in
the response? I do want to store the source but is there a way I can
specify that source should not be part of my query response?

-Amit.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAAOGaQ%2BdmK2rDBV4Pvv2FTD3dbaLFwxH1ac%3D9cwGfmwnH7Ri2Q%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCX6g%3DogP2Uqnn%2BQ4nnT1gpyUq_MGCL77U-h0gbaEz5Pg%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAOGaQKcX1%3DDKGjZnQtHHBKYkqjnKin%2BxZFKVMStwJqz%2Bvx2KA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4