Null id Agent Policy

Using the fleet API, I created a new Agent Policy. But by accident, I provided the ID for the new Policy : "null". Now when I try to view my policies using the UI or the API, I get this :

{"statusCode":500,
"error":"Internal Server Error",
"message":"x_content_parse_exception: [parsing_exception] Reason: No text specified for text query"}

I suppose that the reason is that the request considers the null value as a missing text or no text at all. So I can only access a Policy using his ID that I saved before the bug.

When I tried to delete this null Policy (by using the UI settings or the API delete), the same error appeared. I'm now stuck, I can't see wich Agent Policy is on my deployement, I can't delete or edit the ID of this null Policy. Any clues on what I can try ?

Update : I found a workaround to list all my Agent Policies. That doesn't fix the problem but that's better than nothing. When doing my query with the API, I add

'?kuery=ingest-agent-policies.name:%20(not%20Test%20Null)

Test Null is the name of my glitchy policy.

If you want the solution, here it is : https://github.com/elastic/kibana/issues/131764