[null-valued setting found for key [xpack.security.authc.realms.active_directory]

set active_directory security in elasticsearch.yml. After setting up xpack configuration in the yml file, Elastic service did not start anymore, it indicates that the [null-valued setting found for the active_directory settings. Not sure if there is something missing here.

I also try to use journalctrl to get more info but there is no other error messages to indicate what is the source of the error.

I am upgrading from 6.8.3 to 7.12.

Here is the setting for 7.12 version:

order: 0
url: "ldaps://mydomain.otpp.com:111"
... oher settings here...

Please add your entire active directory realm section and keep formatting. Formatting in YAML is important so we need to know if you have it wrong in your elasticsearch.yml or you just copied it wrong here.

1 Like

It was an issue with the formatting of the yml file. such as, my domain was not indented properly. After this fix, everything works correctly.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.