Observability Lab 2.2 - mysql incorrect creds

Course: Observability Engineer
Version: 7.9

I am currently doing the Observability Engineer Training for version 7.9 and have hit a roadblock in the lab training. In lab 2.2 you set up Metricbeats for MySQL.
I have followed the instructions carefully, done the correct changes to metricbeat.yml and confirmed that the changes are correct. However after enabling the mysql module and doing the changes to modules.d/mysql I am unable to to do step 14 in the lab instructions.
It comes back with an error saying the account details are incorrect for connecting to the mysql instance on the server. Is there anyway of resetting the password for the MySQL instance on mysql server or find out what the correct root password is?

I have tried seeing if I can reset the root password in MySQL but have not had any success.

I will attach screenshots of the mysql.yml file as well as the output I get when I run a test against the mysql module

Hi @deccman , your configuration file looks good.

Did you try running the test command after you setup mysql:3306 as the host and port for the MySQL server? In your first screenshot it looks like it tried instead.

Also, are your executing labs inside the mysql container?


Hi Andre,

I am running the test command with the mysql.yml file set to mysql:3306 in the mysql container.
I have run ps -eaf on the mysql server to make confirm mysql is running. I have also tried running the test command without a password in the mysql.yml file and still have no success.

There are no issues with the metricbeats.yml file, the test command comes back OK.



hi @deccman ,

since you are at the beginning of the training it would be a good idea to replace your environment so you can start over again. Please send me a direct message with your e-mail so I can replace your machine.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.