Org.logstash.beats Invalid frame protocol exception


(sweety) #1

I am trying to send logs to logstash using filebeats
On local machine:

--filebeats
--logstash
--kibana

On server

--elastcisearch

I ran filebeat and logstash on two terminals on my local machine:

  1. ran logstash - bin/logstash -f logstash.conf
  2. in another console ran - sudo ./filebeat -e -v -c filebeat.yml

filbeat.yml:


filebeat.prospectors:

- input_type: log

  paths:
    - /home/sweety/Downloads/logstash-5.4.1/bin/*.log
----------------------------- Logstash output --------------------------------
output.logstash:
  # The Logstash hosts
  hosts: ["127.0.0.1:5044"]

logstash.conf


input { 
beats { 
    port => 5044
  }
 }
output {
  elasticsearch { hosts => ["xxx.xxx.xxx.xx:9200"] }
  stdout { codec => rubydebug }
}

when I ran both filebat and logstash I'm getting
logstash output:

Filebeat output

And when I do http:xxx.xx.xxx:9200/_cat/indices
am not able to see indices in elasticsearch

So I did lot of research on error"Exception: org.logstash.beats.BeatsParser$InvalidFrameProtocolException: Invalid Frame Type, received: 69," but could not able figure it

Could anyone help?

Thanks!


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.